Config Lab: OSPF Network Type

 In 200-301 V1 Ch21: OSPF Network Types, 200-301 V1 Part 6: OSPF, 200-301 V1 Parts, Config Lab, Config Lab CCNA Vol 1 Part 6, Hands-on

The OSPF network type setting happens to be one of the more useful optional OSPF features. This setting changes a couple of details about how OSPF operates on an interface. Ethernet WAN links with two routers only benefit from a change away from the default OSPF network type. This lab asks you to make that specific change.

All about Config Labs

The blog has a series of lab exercises called “Config Labs.” Each lab presents a topology with the relevant initial configuration for each device. The lab also lists new requirements, after which you should create the additional configuration to meet those requirements. You can do the lab on paper, in a text editor, or use software tools like Cisco Packet Tracer or Cisco Modeling Labs.

Once you have created your answer, you can click various tabs at the bottom of this post to see the lab answers, comments about the lab, and other helpful information.

The Lab Exercise

Lab Requirements

By default, OSPF routers elect a Designated Router (DR) and Backup Designated Router (BDR) on Ethernet links, whether LAN or WAN. The routers do so because of the OSPF network type of “broadcast,” the default OSPF network type in Cisco IOS for Ethernet interfaces. The broadcast network type means that:

  1. OSPF dynamically discovers potential OSPF neighbors on the link.
  2. Any OSPF routers on the link elect a DR and BDR. The routers then flood OSPF LSAs using the DR as a central point of control.
  3. The DR creates a Type 2 LSA for the link itself.

Using the OSPF broadcast network type works well with LANs. However, the OSPF broadcast network type adds unnecessary overhead when using Ethernet as a WAN technology, specifically for WAN links with only two routers on the link. By changing the network type on both ends of the link to use network type “point-to-point,” the two routers still dynamically discover each other but do not expend the overhead to elect a DR, follow extra steps to flood LSAs, and do not create a Type 2 LSA for the link.

For this lab, configure the routers to use OSPF network type point-to-point per the following requirements:

  1. Before configuring, based on defaults plus the initial configuration, make these predictions:
    1. Predict how many OSPF neighbors will be displayed with a state of either “FULL/DR” or “FULL/BDR” on each router.
    2. Predict the number of Type 2 LSAs that would exist in the OSPF database.
  2. Configure the OSPF interface network type as follows:
    1. Ethernet WAN links: Make both routers use network type point-to-point.
    2. Ethernet LAN links: Use the default OSPF network type of broadcast.
Router # Neighbors as FULL/DR or FULL/BDR before New Config # Neighbors as FULL/DR or FULL/BDR after New Config
R1
R2
R3
R4

Table 1: Predicting the Number of DR/BDR Neighbors

 

Figure 1: Topology for this Lab

 

Initial Configuration

The configurations on the four routers show a minimal OSPF configuration. It uses mostly default OSPF settings, except that the configurations set the RID for each router.

hostname R1
!
interface GigabitEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 ip ospf 1 area 0
!
interface GigabitEthernet0/0/0
 ip address 172.16.12.1 255.255.255.0
 ip ospf 1 area 0
!
interface GigabitEthernet0/1/0
 ip address 172.16.13.1 255.255.255.0
 ip ospf 1 area 0
!
interface GigabitEthernet0/2/0
 ip address 172.16.14.1 255.255.255.0
 ip ospf 1 area 0
!
router ospf 1
 router-id 1.1.1.1

Example 1: R1 Config

 

hostname R2
!
interface GigabitEthernet0/0
 ip address 172.16.2.2 255.255.255.0
 ip ospf 1 area 0
!
interface GigabitEthernet0/0/0
 ip address 172.16.12.2 255.255.255.0
 ip ospf 1 area 0
!
router ospf 1
 router-id 2.2.2.2

Example 2: R2 Config

 

hostname R3
!
interface GigabitEthernet0/1
 ip address 172.16.2.3 255.255.255.0
 ip ospf 1 area 0
!
interface GigabitEthernet0/0/0
 ip address 172.16.13.3 255.255.255.0
 ip ospf 1 area 0
!
router ospf 1
 router-id 3.3.3.3

Example 3: R3 Config

 

hostname R4
!
interface GigabitEthernet0/0
 ip address 172.16.4.4 255.255.255.0
 ip ospf 1 area 0
!
interface GigabitEthernet0/0/0
 ip address 172.16.14.4 255.255.255.0
 ip ospf 1 area 0
!
router ospf 1
 router-id 4.4.4.4

Example 4: R4 Config

 

The lab does not call for any switches or PCs. Note that if you add them yourself, you can use all default configuration in a Cisco switch for this lab, which would place all devices connected to a switch in the same VLAN.

Answer Options - Click Tabs to Reveal

You can learn a lot and strengthen real learning of the topics by creating the configuration – even without a router or switch CLI. In fact, these labs were originally built to be used solely as a paper exercise!

To answer, just think about the lab. Refer to your primary learning material for CCNA, your notes, and create the configuration on paper or in a text editor. Then check your answer versus the answer post, which is linked at the bottom of the lab, just above the comments section.

You can also implement the lab using the Cisco Packet Tracer network simulator. With this option, you use Cisco’s free Packet Tracer simulator. You open a file that begins with the initial configuration already loaded. Then you implement your configuration and test to determine if it met the requirements of the lab.

(Use this link for more information about Cisco Packet Tracer.)

Use this workflow to do the labs in Cisco Packet Tracer:

  1. Download the .pkt file linked below.
  2. Open the .pkt file, creating a working lab with the same topology and interfaces as the lab exercise.
  3. Add your planned configuration to the lab.
  4. Test the configuration using some of the suggestions below.

Download this lab’s Packet Tracer File

You can also implement the lab using Cisco Modeling Labs – Personal (CML-P). CML-P (or simply CML) replaced Cisco Virtual Internet Routing Lab (VIRL) software in 2020, in effect serving as VIRL Version 2.

If you prefer to use CML, use a similar workflow as you would use if using Cisco Packet Tracer, as follows:

  1. Download the CML file (filetype .yaml) linked below.
  2. Import the lab’s CML file into CML and then start the lab.
  3. Compare the lab topology and interface IDs to this lab, as they may differ (more detail below).
  4. Add your planned configuration to the lab.
  5. Test the configuration using some of the suggestions below.

Download this lab’s CML file!

 

Network Device Info:

This table lists the interfaces listed in the lab exercise documentation versus those used in the sample CML file.

Device Lab Port  CML Port
R1 G0/0/0 G0/3
R1 G0/1/0 G0/1
R1 G0/2/0 G0/2
R2 G0/0/0 G0/2
R3 G0/0/0 G0/2
R4 G0/0/0 G0/2

Lab Answers Below: Spoiler Alert

Lab Answers: Configuration (Click Tab to Reveal)

Lab Answers

 

Figure 1: Topology for this Lab

 

Example 1: R1 Config

interface GigabitEthernet0/0/0
 ip ospf network point-to-point
!
interface GigabitEthernet0/1/0
 ip ospf network point-to-point
!
interface GigabitEthernet0/2/0
 ip ospf network point-to-point

 

Example 2: R2 Config

interface GigabitEthernet0/0/0
 ip ospf network point-to-point

 

Example 3: R3 Config

interface GigabitEthernet0/0/0
 ip ospf network point-to-point

 

Example 4: R4 Config

interface GigabitEthernet0/0/0
 ip ospf network point-to-point

Commentary, Issues, and Verification Tips (Click Tabs to Reveal)

Lab Commentary

Focus on the three WAN links in the figure for this lab. All three use Ethernet interfaces on the router, and all three links use a point-to-point topology. In other words, each Ethernet link has two and only two devices connected to it. (Ethernet WANs allow for more than two routers connected to the same link – which is not the case for this topology.)

Because only two routers exist on each link, you can change each link to use OSPF network type point-to-point – but you must configure the setting on both routers on both ends of the links. Those pairs are: 

  • R1 G0/0/0 and R2 G0/0/0
  • R1 G0/1/0 and R3 G0/0/0
  • R1 G0/2/0 and R4 G0/0/0 

Note that if you configured the ip ospf network point-to-point on one end of a link, and left the other with a default setting of ip ospf network broadcast, then the two routers would not form a neighbor relationship.

The configuration itself is straightforward: enter configuration mode for each interface and add the ip ospf network point-to-point command.

 

Also, the lab asked you to consider two questions before doing the lab. Here are a few notes about those:

  1. The question asked: How many neighbors will be listed as FULL/DR and FULL/BDR on each router? After making all the WAN links use network type point-to-point, the routers should not list their WAN neighbors as either FULL/DR nor FULL/BDR. The DR and BDR features are not used on links with network type point-to-point. However, note that R2 and R3 connect to the same LAN subnet, so they should each list one neighbor (each other) as either FULL/DR or BULL/BDR state.
  2. The question asked: How many type 2 LSAs will exist? OSPF creates a type 2 LSA for each subnet with (a) a DR and (b) two or more routers connect to the subnet. For instance, the subnet on the LAN connected to R1 has a DR, but no second router, so there’s no type 2 LSA for that subnet. Again, only the R2-R3 subnet meets both criteria, so only one type 2 LSA should exist.

Known Issues in this Lab

This section of each Config Lab Answers post hopes to help with those issues by listing any known issues with Packet Tracer related to this lab. In this case, the problems are:

# Summary Detail
1 Reload may help In our testing, at PT 8.0, after making the configuration change, the neighbors did not recover as they would on real gear. However, if you issue a copy running-config startup-config command to save your config and the reload command on both routers, the routers then become neighbors.

 

Why Would Cisco Packet Tracer Have Issues?

(Note: The below text is the same in every Config Lab.)

Cisco Packet Tracer (CPT) simulates Cisco routers and switches. However, CPT does not run the same software that runs in real Cisco routers and switches. Instead, developers wrote CPT to predict the output a real router or switch would display given the same topology and configuration – but without performing all the same tasks, an actual device has to do. On a positive note, CPT requires far less CPU and RAM than a lab full of devices so that you can run CPT on your computer as an app. In addition, simulators like CPT help you learn about the Cisco router/switch user interface – the Command Line Interface (CLI) – without having to own real devices.

CPT can have issues compared to real devices because CPT does not run the same software as Cisco devices. CPT does not support all commands or parameters of a command. CPT may supply output from a command that differs in some ways from what an actual device would give. Those differences can be a problem for anyone learning networking technology because you may not have experience with that technology on real gear – so you may not notice the differences. So this section lists differences and issues that we have seen when using CPT to do this lab.

Beyond comparing your answers to this lab’s Answers post, you can test in Cisco Packet Tracer (CPT) or Cisco Modeling Labs (CML). In fact, you can and should explore the lab once configured. For this lab, once you have completed the configuration, try these verification steps. 

  1. Find the interface type on each interface using the show ip ospf interface command.

More Labs with Related Content!

Config Lab: OSPF DR Priority
Config Lab: OSPF Router IDs
Subscribe
Notify of
guest

2 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
John rambo

Hello thank you once again for making the lab, may I ask what is the answer for:

Predict how many OSPF neighbors will be displayed with a state of either “FULL/DR” or “FULL/BDR” on each router.

Predict the number of Type 2 LSAs that would exist in the OSPF database.

Thank you

Tewa

Hello Wendell,

I am confused by your answer to “Predict the number of Type 2 LSAs that would exist in the OSPF database.”

You indicated that only 1 type 2 (network) LSA will exist in the database. Why is that? There are 3 WAN ethernet links and 1 LAN ethernet link in the topology and I predicted 4 type 2 LSA.
My reasoning is as follows:
Take the link between R1 G0/0/0 and R2 G0/0/0, they are both in the same subnet and when they both come up they will elect a DR which will be R2 assuming all defaults. In this case, on this link there is a DR (R2) and it will list R1 as a neighbor thus meeting the criteria for network type 2. Same reasoning applies to the rest of the WAN links in the topology plus the LAN link hence my prediction of 4 type 2 LSAs. Please let me know if this reasoning is incorrect.
Also there is a similar topology in the CCNA guide fig 19-7 and there you listed 3 type 2 LSA based on this reasoning. Did I miss something?

Tewa

Thank you Wendell for the clarification. At least now I know am not loosing my mind.
But I still think the answer is not quite right because the question stem says:
Before configuring, based on defaults plus the initial configuration, make these predictions”
We are assuming defaults here (which means broadcast is in use) and point-to-point interface subcommand has not yet been configured as per the initial configuration. I think the answer you provided will be valid if we are making prediction after the point-to-point configuration. Please let me know your thoughts.

2
0
Would love your thoughts, please comment.x
()
x