Config Lab: IPv4 Addresses 1

 In 200-301 V1 Ch16: Router Addresses and Routes, 200-301 V1 Part 5: IPv4 Routing, 200-301 V1 Parts, Config Lab, Config Lab CCNA Vol 1 Part 4, Config Lab CCNA Vol 1 Part 5, Hands-on

The next lab combines a little bit of subnetting math with IP address configuration. If you know how to calculate the IP addresses in a subnet and how to configure IP addresses, make this one a speed test. See how long it takes you from reading the specifics until you can type the config!

All about Config Labs

The blog has a series of lab exercises called “Config Labs.” Each lab presents a topology with the relevant initial configuration for each device. The lab also lists new requirements, after which you should create the additional configuration to meet those requirements. You can do the lab on paper, in a text editor, or use software tools like Cisco Packet Tracer or Cisco Modeling Labs.

Once you have created your answer, you can click various tabs at the bottom of this post to see the lab answers, comments about the lab, and other helpful information.

The Lab Exercise

Requirements

Configure the IP addresses for the LAN interfaces for the routers shown in the figure, per the subnets listed in the figure. The specific rules for this lab are:

  1. Assign the core router’s interfaces with the highest IP address from each subnet.
  2. Configure the Branch routers interfaces connected to the Core router with the next highest remaining available IP address in each subnet (after the Core router interface IP addresses.)
  3. Configure the other interfaces on the Branch routers – the interfaces connected to user PCs – with the highest IP address in each subnet.
  • Assumptions:
    • Assume all device interfaces shown in the lab are up and working.
    • Assume that the PCs are pre-configured with the correct IP addresses.

 

Figure 1: Simple Hub and Spoke Topology

 

Initial Configuration

Examples 1, 2, 3, and 4 show the beginning configuration state of Core, Branch1, Branch2, and Branch3.

 

hostname Core
!
interface GigabitEthernet0/0
 no shutdown
!
interface GigabitEthernet0/1
 no shutdown
!
interface GigabitEthernet0/2
 no shutdown
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

Example 1: Core Config

 

hostname Branch1
!
interface GigabitEthernet0/1
 no shutdown
!
interface GigabitEthernet0/2
 no shutdown
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

Example 2: Branch1 Config

 

hostname Branch2
!
interface GigabitEthernet0/1
 no shutdown
!
interface GigabitEthernet0/2
 no shutdown
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

Example 3: Branch2 Config

 

hostname Branch3
!
interface GigabitEthernet0/1
 no shutdown
!
interface GigabitEthernet0/2
 no shutdown
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

Example 4: Branch3 Config

Answer Options - Click Tabs to Reveal

You can learn a lot and strengthen real learning of the topics by creating the configuration – even without a router or switch CLI. In fact, these labs were originally built to be used solely as a paper exercise!

To answer, just think about the lab. Refer to your primary learning material for CCNA, your notes, and create the configuration on paper or in a text editor. Then check your answer versus the answer post, which is linked at the bottom of the lab, just above the comments section.

You can also implement the lab using the Cisco Packet Tracer network simulator. With this option, you use Cisco’s free Packet Tracer simulator. You open a file that begins with the initial configuration already loaded. Then you implement your configuration and test to determine if it met the requirements of the lab.

(Use this link for more information about Cisco Packet Tracer.)

Use this workflow to do the labs in Cisco Packet Tracer:

  1. Download the .pkt file linked below.
  2. Open the .pkt file, creating a working lab with the same topology and interfaces as the lab exercise.
  3. Add your planned configuration to the lab.
  4. Test the configuration using some of the suggestions below.

Download this lab’s Packet Tracer File

You can also implement the lab using Cisco Modeling Labs – Personal (CML-P). CML-P (or simply CML) replaced Cisco Virtual Internet Routing Lab (VIRL) software in 2020, in effect serving as VIRL Version 2.

If you prefer to use CML, use a similar workflow as you would use if using Cisco Packet Tracer, as follows:

  1. Download the CML file (filetype .yaml) linked below.
  2. Import the lab’s CML file into CML and then start the lab.
  3. Compare the lab topology and interface IDs to this lab, as they may differ (more detail below).
  4. Add your planned configuration to the lab.
  5. Test the configuration using some of the suggestions below.

Download this lab’s CML file!

 

Network Device Info:

This table lists the interfaces used in the lab exercise documentation that differ from those used in the sample CML file.

Device Lab Port  CML Port
Core G0/0 G0/3

Lab Answers Below: Spoiler Alert

Lab Answers: Configuration (Click Tab to Reveal)

Answers

Figure 1: Simple Hub and Spoke Topology

 

interface GigabitEthernet0/0
 ip address 172.16.1.214 255.255.255.248
!
interface GigabitEthernet0/1
 ip address 172.16.1.206 255.255.255.248
!
interface GigabitEthernet0/2
 ip address 172.16.1.198 255.255.255.248 

Example 1: Core Config

 

interface GigabitEthernet0/1
 ip address 172.16.1.205 255.255.255.248
!
interface GigabitEthernet0/2
 ip address 172.16.1.62 255.255.255.192

Example 2: Branch1 Config

 

interface GigabitEthernet0/1
 ip address 172.16.1.197 255.255.255.248
!
interface GigabitEthernet0/2
 ip address 172.16.1.126 255.255.255.192

Example 3: Branch2 Config

 

interface GigabitEthernet0/1
 ip address 172.16.1.213 255.255.255.248
!
interface GigabitEthernet0/2
 ip address 172.16.1.190 255.255.255.192

Example 4: Branch3 Config

Commentary, Issues, and Verification Tips (Click Tabs to Reveal)

Commentary

Every network engineer has to plan for and configure IP addresses. That process includes calculating subnet IDs, the range of addresses in each subnet, and choosing the addresses to use for router interfaces. Once planned, configuring the address and mask takes only a straightforward command: The ip address ip-address subnet-mask command in interface configuration mode.

This lab tasks you with configuring the IP addresses for all of the router interfaces and calculating the IP addresses to use based on the documentation shown. For the sake of discussion, this section works through the numbered requirements (1, 2, and 3) in order.

First, on the Core router, that router has three interfaces connecting to the Branches. The interface connecting to ‘Branch1’ is the GigabitEthernet0/1 interface, which has been assigned to the 172.16.1.200/29 subnet. That subnet includes usable IP addresses 172.16.1.201 through 172.16.1.206, so the highest useable IP address in this subnet is 172.16.1.206. The mask in DDN notation is 255.255.255.248, which is the equivalent of /29.

Continuing the discussion of router Core, the interface connecting to ‘Branch2’ is the GigabitEthernet0/2 interface which has been assigned to the 172.16.1.192/29 subnet; the highest useable IP address in this subnet is 172.16.1.198 using a subnet mask of 255.255.255.248. Finally, the interface connecting to ‘Branch3’ is the GigabitEthernet0/0 interface which has been assigned to the 172.16.1.208/29 subnet; the highest useable IP address in this subnet is 172.16.1.214 using a subnet mask of 255.255.255.248.

Requirement number 2 asks us to configure the branch router interfaces on the links that connect to the core router. The above discussion has already detailed the subnets, so all you have to do is pick the highest remaining IP address. Table 1 lists the addresses used on both the Core router and the Branch router on the other end of each link.

Link Subnet Core Address Branch Address
Core to Branch1 172.16.1.200/29 172.16.1.206 172.16.1.205
Core to Branch2 172.16.1.192/29 172.16.1.198 172.16.1.197
Core to Branch3 172.16.1.208/29 172.16.1.214 172.16.1.213

Table 1: WAN Subnets and Address Assignments

 

Finally, for requirement 3, you need to calculate the range of addresses in three more subnets and use the highest address for the router interface IP addresses. Table 2 lists those details.

Link Subnet First Usable Address Last Usable Address (Router Address)
Branch1 172.16.1.0/26 172.16.1.1 172.16.1.62
Branch2 172.16.1.64/26 172.16.1.65 172.16.1.126
Branch3 172.16.1.128/26 172.16.1.129 172.16.1.190

Table 2: Branch LAN Subnet Analysis

 

Once you complete all the calculations, the task is simple: configure the ip address commands as listed in Examples 1, 2, 3, and 4.

Known Issues in this Lab

This section of each Config Lab Answers post hopes to help with those issues by listing any known issues with Packet Tracer related to this lab. In this case, the issues are:

# Summary Detail
1 None No known issues related to this lab.

 

Why Would Cisco Packet Tracer Have Issues?

(Note: The below text is the same in every Config Lab.)

Cisco Packet Tracer (CPT) simulates Cisco routers and switches. However, CPT does not run the same software that runs in real Cisco routers and switches. Instead, developers wrote CPT to predict the output a real router or switch would display given the same topology and configuration – but without performing all the same tasks, an actual device has to do. On a positive note, CPT requires far less CPU and RAM than a lab full of devices so that you can run CPT on your computer as an app. In addition, simulators like CPT help you learn about the Cisco router/switch user interface – the Command Line Interface (CLI) – without having to own real devices.

CPT can have issues compared to real devices because CPT does not run the same software as Cisco devices. CPT does not support all commands or parameters of a command. CPT may supply output from a command that differs in some ways from what an actual device would give. Those differences can be a problem for anyone learning networking technology because you may not have experience with that technology on real gear – so you may not notice the differences. So this section lists differences and issues that we have seen when using CPT to do this lab.

Beyond comparing your answers to this lab’s Answers post, you can test in Cisco Packet Tracer (CPT) or Cisco Modeling Labs (CML). In fact, you can and should explore the lab once configured. For this lab, once you have completed the configuration, try these verification steps. 

  1. From the console of each router, verify the router’s IP addresses:
    1. Use the show ip interface command to verify the address and mask.
    2. Use the show ip interfaces brief command to verify the addresses.
    3. Use the ping command against the addresses expected to be configured on the local router; all pings should work.
  2. The initial configuration shows a pre-configured routing protocol so that all routers to learn all routes dynamically.  To confirm from each router:
    1. Use the show ip route command and confirm the router sees routes for all six subnets in the figure.
  3. Use ping tests to ping the router IP address on the opposite end of each link:
    1. From Branch1, Branch2, and Branch3, ping Core1’s IP address on the respective WAN links.
    2. From Core1, ping the WAN IP addresses of Branch1, Branch2, and Branch3, all of which exist on a WAN subnet connected to Core1.

More Labs with Related Content!

Config Lab: L2 EtherChannel 2
Config Lab: IPv4 Addresses 2
Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
ERMUNDO C RUSSELL

Hey Wendell,

The verification tips for CPT/CML tab says the initial configuration on the routers show EIGRP pre-configured but when you look at the running config or the startup config it lists OSPF process id 1 area 0. I didn’t see EIGRP anywhere in the config. Let me know if I am missing something and thank you in advance.

0
Would love your thoughts, please comment.x
()
x