Config Lab: L3 EtherChannel 1
Layer 3 switches, SVIs, routed ports, and L3 EtherChannels. Those topics alone make this lab fairly advanced for CCNA prep. Today’s lab focuses on the L3 EtherChannel, but also gives you a chance to configure the rest of the features in the initial list as well.
The Lab Exercise
Requirements
In this lab, you will add configuration to distribution switches Dist1 and Dist2. These two layer 3 switches will route packets for several subnets. Dist1 connects to the subnets supported by VLANs 10 and 20, while Dist2 connects to those supported by VLANs 30 and 40. The two distribution switches connect with a layer 3 EtherChannel with two links.
Your job: configure the SVIs (VLAN interfaces) necessary for routing the connected subnets on the access VLANs. The IP addresses on these SVIs will be used by the PCs in the network as their default gateway IP addresses. Then configure the layer 3 EtherChannel between the switches, providing a layer 3 link between the two distribution switches so that they can route packets to each other.
This lab begins with several key features pre-configured. Make sure to pay close attention to the initial configurations to get your bearings before starting to do the lab. These items are preconfigured:
- The links connecting the Access switches with their Distribution switches are preconfigured as static trunks using 802.1q encapsulation.
- The access and distribution switches have been pre-configured with the VLAN IDs listed in the figure.
- All interfaces shown in the figure have been administratively enabled.
- Layer 3 switches Dist1 and Dist2 have been pre-configured with OSPF so that once the lab has been configured, Dist1 and Dist2 will exchange IPv4 routes.
The following list details your work for this lab:
- Configure Layer 3 switching with SVIs on the two distribution switches as follows:
- Switch Dist1 routes for VLANs 10 and 20
- Switch Dist2 routes for VLANs 30 and 40
- Configure a layer 3 EtherChannel for the two links between switches Dist1 and Dist2 so that IPv4 packets can be routed between the two switches, as follows:
- Configure the two links between the distribution switches as a static layer 3 EtherChannel with port-channel interface number 10.
- Make the EtherChannel a routed port instead of a switch port.
- Configure the IP addresses per the figure for the PortChannel interface
Figure 1: Switch Square w/L3 EtherChannel Topology
Initial Configuration
Examples 1, 2, 3, and 4 show the beginning configuration state of Dist1, Dist2, Access1, and Access2.
hostname Dist1
!
interface GigabitEthernet1/1/1
no shutdown
!
interface GigabitEthernet1/1/2
no shutdown
!
interface GigabitEthernet1/1/3
no shutdown
switchport trunk encapsulation dot1q
switchport mode trunk
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
Example 1: Dist1 Config
hostname Dist2
!
interface GigabitEthernet1/1/1
no shutdown
!
interface GigabitEthernet1/1/2
no shutdown
!
interface GigabitEthernet1/1/3
no shutdown
switchport trunk encapsulation dot1q
switchport mode trunk
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
Example 2: Dist2 Config
hostname Access1
!
vlan 10,20
!
interface GigabitEthernet1/1/1
no shutdown
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2
no shutdown
switchport access vlan 10
!
interface GigabitEthernet1/0/3
no shutdown
switchport access vlan 20
Example 3: Access1 Config
hostname Access2
!
vlan 30,40
!
interface GigabitEthernet1/1/1
no shutdown
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2
no shutdown
switchport access vlan 30
!
interface GigabitEthernet1/0/3
no shutdown
switchport access vlan 40
Example 4: Access2 Config
Answer Options - Click Tabs to Reveal
You can learn a lot and strengthen real learning of the topics by creating the configuration – even without a router or switch CLI. In fact, these labs were originally built to be used solely as a paper exercise!
To answer, just think about the lab. Refer to your primary learning material for CCNA, your notes, and create the configuration on paper or in a text editor. Then check your answer versus the answer post, which is linked at the bottom of the lab, just above the comments section.
You can also implement the lab using the Cisco Packet Tracer network simulator. With this option, you use Cisco’s free Packet Tracer simulator. You open a file that begins with the initial configuration already loaded. Then you implement your configuration and test to determine if it met the requirements of the lab.
(Use this link for more information about Cisco Packet Tracer.)
Use this workflow to do the labs in Cisco Packet Tracer:
- Download the .pkt file linked below.
- Open the .pkt file, creating a working lab with the same topology and interfaces as the lab exercise.
- Add your planned configuration to the lab.
- Test the configuration using some of the suggestions below.
You can also implement the lab using Cisco Modeling Labs – Personal (CML-P). CML-P (or simply CML) replaced Cisco Virtual Internet Routing Lab (VIRL) software in 2020, in effect serving as VIRL Version 2.
If you prefer to use CML, use a similar workflow as you would use if using Cisco Packet Tracer, as follows:
- Download the CML file (filetype .yaml) linked below.
- Import the lab’s CML file into CML and then start the lab.
- Compare the lab topology and interface IDs to this lab, as they may differ (more detail below).
- Add your planned configuration to the lab.
- Test the configuration using some of the suggestions below.
Download this lab’s CML file!
Network Device Info:
This table lists the interfaces listed in the lab exercise documentation versus those used in the sample CML file.
Device | Lab Port | Â CML Port |
Dist1 | G1/1/1 | G0/1 |
Dist1 | G1/1/2 | G0/2 |
Dist1 | G1/1/3 | G0/3 |
Dist2 | G1/1/1 | G0/1 |
Dist2 | G1/1/2 | G0/2 |
Dist2 | G1/1/3 | G0/3 |
Access1 | G1/1/1 | G0/1 |
Access1 | G1/0/2 | G0/2 |
Access1 | G1/0/3 | G0/3 |
Access2 | G1/1/1 | G0/1 |
Access2 | G1/0/2 | G0/2 |
Access2 | G1/0/3 | G0/3 |
Host device info:
This table lists host information pre-configured in CML, information that might not be required by the lab but may be useful to you.
Device |
IP Address |
User/password |
PC1 |
10.100.100.2/27 |
cisco/cisco |
PC2 |
10.100.100.34/27 |
cisco/cisco |
PC3 |
10.100.100.66/27 |
cisco/cisco |
PC4 |
10.100.100.98/27 |
cisco/cisco |
Lab Answers Below: Spoiler Alert
Lab Answers: Configuration (Click Tab to Reveal)
Answers
Figure 1: Switch Square w/L3 EtherChannel Topology
ip routing
!
vlan 10,20
!
interface Port-Channel10
no switchport
ip address 100.1.2.1 255.255.255.240
!
interface GigabitEthernet1/1/1
no switchport
channel-group 10 mode on
!
interface GigabitEthernet1/1/2
no switchport
channel-group 10 mode on
!
interface Vlan10
ip address 10.100.100.1 255.255.255.224
no shutdown
!
interface Vlan20
ip address 10.100.100.33 255.255.255.224
no shutdown
Example 5: Dist1 Config
ip routing
!
vlan 30,40
!
interface Port-Channel10
no switchport
ip address 100.1.2.14 255.255.255.240
!
interface GigabitEthernet1/1/1
no switchport
channel-group 10 mode on
!
interface GigabitEthernet1/1/2
no switchport
channel-group 10 mode on
!
interface Vlan30
ip address 10.100.100.65 255.255.255.224
no shutdown
!
interface Vlan40
ip address 10.100.100.97 255.255.255.224
no shutdown
Example 6: Dist2 Config
Commentary, Issues, and Verification Tips (Click Tabs to Reveal)
Commentary
In most modern networks, it has become standard that layer 3 switches are typically preferred over their router counterparts in the LAN. Layer 3 switches often support much higher packet forwarding volumes than routers of a similar price-point. Also, performing layer 3 forwarding inside a switch, versus Router-on-a-Stick, removes the trip over a cable to a router and back over the same cable to the switch. In modern enterprise networks, routers often sit only at the edge of the WAN, with switches connecting all the devices in a campus or a Data Center.
With this lab, you were tasked with configuring two distribution switches to act as layer 3 switches. Two access layer switches, operating only with layer 2 features, were pre-configured with those features and VLANs. Two two distribution switches act as the default gateway for the hosts in the VLANs shown in the figure.
First, looking at switch Dist1, it has three different interfaces. Two interfaces will be grouped together into a layer 3 EtherChannel link that connects to switch Dist2. Dist1’s other interface is the pre-configured trunk port that connects to switch Access1.
First, to configure the EtherChannel on the two links between the two distribution switches, you could start with the interface range gigabitethernet1/1/1 – 2 command so that upcoming interface subcommands would apply to both interfaces. Then add the no switchport command to convert the interfaces into a routed layer 3 interface and the channel-group 10 mode on command to group them together into an EtherChannel. Note that the channel-group command automatically creates the Port-Channel 10 interface.
The PortChannel interface also needs to be configured as a routed port, and then it also needs an IPv4 address. To do so, use the interface port-channel 10 command to get into interface config mode and configure the no switchport command to make the port-channel interface a routed port. Then configure the IP address using the ip address 100.1.2.1 255.255.255.240 command.
The configuration of the L3 EtherChannel on switch Dist2 follows the same basic steps: configure the physical ports to be in the same channel-group (using the channel-group command), making the ports routed ports (no switchport), making the port-channel interface a routed port, and assigning the port-channel interface an IPv4 address.
To configure switch Dist1 to have a layer 3 interface connected to the subnets in VLANs 10 and 20, the switch needs configuration for both the VLANs and the associated VLAN interfaces. Configuring the VLANs requires two simple global commands: vlan 10 and vlan 20. Switch Dist1 must then configure VLAN interfaces 10 and 20. To configure the interface for VLAN 10, use the interface vlan 10 command, with an IP address configured with the ip address 10.100.100.1 255.255.255.224 command to match the information in the figure. Similarly, use the interface vlan 20 command and the ip address 10.100.100.33 255.255.255.224 command to configure the SVI for VLAN 20.
Switch Dist2 again follows a similar pattern, but for VLANs 30 and 40 in this case. Configuring the VLANs requires the vlan 30 and vlan 40 global commands. To configure the VLAN 30 interface, use the interface vlan 30 command, and to configure the IP address, use the ip address 10.100.100.65 255.255.255.224 command. To configure the VLAN 40 interface, use the interface vlan 40 command, and to configure its IP address, use the ip address 10.100.100.97 255.255.255.224 command.
Known Issues in this Lab
This section of each Config Lab Answers post hopes to help with those issues by listing any known issues with Packet Tracer related to this lab. In this case, the issues are:
# | Summary | Detail |
1 | None | No known issues related to this lab. |
Why Would Cisco Packet Tracer Have Issues?
(Note: The below text is the same in every Config Lab.)
Cisco Packet Tracer (CPT) simulates Cisco routers and switches. However, CPT does not run the same software that runs in real Cisco routers and switches. Instead, developers wrote CPT to predict the output a real router or switch would display given the same topology and configuration – but without performing all the same tasks, an actual device has to do. On a positive note, CPT requires far less CPU and RAM than a lab full of devices so that you can run CPT on your computer as an app. In addition, simulators like CPT help you learn about the Cisco router/switch user interface – the Command Line Interface (CLI) – without having to own real devices.
CPT can have issues compared to real devices because CPT does not run the same software as Cisco devices. CPT does not support all commands or parameters of a command. CPT may supply output from a command that differs in some ways from what an actual device would give. Those differences can be a problem for anyone learning networking technology because you may not have experience with that technology on real gear – so you may not notice the differences. So this section lists differences and issues that we have seen when using CPT to do this lab.
Beyond comparing your answers to this lab’s Answers post, you can test in Cisco Packet Tracer (CPT) or Cisco Modeling Labs (CML). In fact, you can and should explore the lab once configured. For this lab, once you have completed the configuration, try these verification steps.Â
- Check that the VLANs have been created using the show vlan brief and show interfaces interface switchport commands on the distribution switches.
- Check that the VLAN interfaces were configured with the show ip interfaces brief and/or show running-config commands.
- Check that the trunks are operational using the show interfaces trunk command.
For the layer 3 specifics, check on the L3 EtherChannel, the SVIs, and make sure OSPF is working:
- Verify the state of the L3 EtherChannel using the show etherchannel summary command.
- Check the port-channel interface using the show interfaces port-channel10 command.
- The show interfaces status command should list the physical ports in the channel and interface portchannel10 as a routed port rather than being assigned to a VLAN.
- Also, each distribution (layer 3) switch should list three connected IPv4 routes in the output of the show ip route command.
Am I the only one who sees yellow dots on the interfaces that are part of the etherchannel in packet tracer? My version is 8.1.0.0722.
I see those dots too. I think it’s PacketTracer’s way of denoting that not all the interfaces are “up” in the way that individual interfaces would be.
Command “no switchport” does not working when i trying to implement this command on PortChannel
Dist1(config-if)#no switchport
% Incomplete command.
Evgeniy,
Not sure what’s happening. First, clarify:
1) What tool? Packet Tracer (if so, the version), CML (if so, the version), real gear (model, version)
2) what interface?
FYI, here’s what I get when just trying the “no switchport” commands from Packet Tracer- both are accepted.
Dist1>ena
Dist1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Dist1(config)#int g1/1/1
Dist1(config-if)#no switchport
Dist1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1/1, changed state to up
Dist1(config-if)#int po1
Dist1(config-if)#no switchport
Dist1(config-if)#
Dist1(config-if)#
I’m using packet tracer 8.1.1.0022 and also getting error when executing “no switchport” on the interface. On the port-channel it is working.
ist1(config)#interface range gi 1/1/1-2
Dist1(config-if-range)#no switchport
Command rejected (Port-channel): Either port is L2 and port-channel is L3, or vice-versa
Command rejected (Port-channel): Either port is L2 and port-channel is L3, or vice-versa
Dist1(config)#interface gi 1/1/1
Dist1(config-if)#no switchport
Command rejected (Port-channel): Either port is L2 and port-channel is L3, or vice-versa
Hello Wendell,
I am using Packer Tracer Version 8.2.1.0118 and I get the same error message as Evgeniy. I was however able to ping all PCs from PC1. Please see below:
Dist1(config-if)#int po10
Dist1(config-if)#no sw
% Incomplete command.
Dist1(config-if)#no switchport
% Incomplete command.
Dist1(config-if)#
Dist2(config-if)#int po10
Dist2(config-if)#no sw
% Incomplete command.
Dist2(config-if)#no switchport
% Incomplete command.
Dist2(config-if)#
Hi all,
Looks like 8.1.x doesn’t support the command. It works well for me with 8.2.x. If interested, try the latest Cisco Packet Tracer, which today is some 8.2.x version.I tested on 8.2.0.0166. I downloaded it and it’s 8.2.1.118.
Hello Wendell!
Thanks again for your labs! I receive the same message “incomplete command” that Evgeniy gets. I am running packet tracer 8.1.1.0022. However, when I put port-channel 10 in up/up status, OSPF still recognizes the port-channel and advertises routes successully. Perhaps a slight difference in PT as compared to real gear or CML?
Sure thing, KG.
Are you in portchannel interface mode or Gigabit/whatever mode? My recent test (in my recent earlier comment above) was in Gigabit1/1/1 mode. Maybe the PT logic issue is it not accepting the command after getting into portchannel interface mode? If you see this, let me know, as I’m not where I can test this week. Thanks…
Hi Wendell,
I have two doubts while doing this lab in Packet Tracer v 8.2.0.0162
1. I get the same 2 amber dots in one of the links of the etherchannel, as Emil and Clear comment. Is that normal?
2. The output of “show interfaces port-channel 10” shows Half-duplex, 2100Mb/s. Is that normal too?
Thanks for sharing your knowledge with us all.
Hi Vicente,
On don’t get the amber or yellow dots. I wondered if there’s some PT settings that allows them to be seen, but I couldn’t find one. Sorry, no help there.
On #2, PT is inaccurate there. I happened to have a couple of portchannels configured on a 9200L just now, and checked, and the show int portchannel whatever listed the same duplex as the physical (full duplex) and the speed of a single interface. EG below.
SW1#show etherchannel sum
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator
M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port
A – formed by Auto LAG
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) – Gi1/0/21(P) Gi1/0/22(P)
12 Po12(RU) – Te1/1/1(P) Te1/1/2(P)
SW1#show int po1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 4488.165a.f216 (bia 4488.165a.f216)
MTU 1500 bytes, BW 2000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is N/A
Hi Wendell not sure if this is the expected outcome but I enabled the routed interface on the port channel interface before doing so on the physical interfaces and received an error –
Dist1(config)#int range g1/1/1-2
Dist1(config-if-range)#no switchport
Command rejected (Port-channel): Either port is L2 and port-channel is L3, or vice-versa
I had to remove both interfaces from the etherchannel then I was able to input the no switchport command and readd them to the port channel after and everything worked as expected.
Thanks for this tip; I was scratching my head at L2 and L3 until I put it together that the L3 switch was allowing an IP address on a “switchport”. To fix this, I ran the following
no interface port-channel 10
no ip address
Thanks for this tip!
L2 likely wouldn’t allow an IP address and L3 would allow it without having to use “no switchport” so to back it out use:
no interface port-channel 10
Hi Wendell,
In my case I faced too the green dot but after restarting the Packet tracer, it was removed.
But I have another issue, as I cannot bring VSI up on both distro switches
p.e.
“`
Dist1#show interfaces Vlan 10
Vlan10 is down, line protocol is down
Hardware is CPU Interface, address is 0005.5e3d.5a01 (bia 0005.5e3d.5a01)
Internet address is 10.100.100.1/27
“`
Here is my running config:
“`
Dist1#show running-config
Building configuration…
Current configuration : 1937 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Dist1
!
no ip cef
ip routing
!
no ipv6 cef
!
no ip domain-lookup
!
!
vtp mode transparent
!
spanning-tree mode pvst
!
interface Port-channel10
no switchport
ip address 100.1.2.1 255.255.255.240
!
interface GigabitEthernet1/0/1
………………………………………………..
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
no switchport
no ip address
channel-group 10 mode on
duplex auto
speed auto
!
interface GigabitEthernet1/1/2
no switchport
no ip address
channel-group 10 mode on
duplex auto
speed auto
!
interface GigabitEthernet1/1/3
switchport mode trunk
!
interface GigabitEthernet1/1/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0005.5e3d.5a01
ip address 10.100.100.1 255.255.255.224
!
interface Vlan20
mac-address 0005.5e3d.5a02
ip address 10.100.100.33 255.255.255.224
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
ip flow-export version 9
!
line con 0
exec-timeout 0 0
!
line aux 0
!
line vty 0 4
login
!
end
“`
Also, I cant ping any host from PC1….
I assume that this caused by the vlan10 int being down:
”
1. The frame destination MAC address is broadcast. The Multilayer Switch processes the frame.
2. The frame’s destination MAC address matches the receiving port’s MAC address, the broadcast address, or a multicast address.
3. The device decapsulates the PDU from the Ethernet frame.
4. The frame is an ARP frame. The ARP process processes it.
5. The active VLAN interface is not up. The ARP process ignores the frame.
“
Its seems that finally I have fixed that. Among with others, we need also to configure vlans on dist switches as well. There is no need to assigned any port on them. Just creating them and then svis become up and everything works ok.
Panagiotis,
Glad you got it working!
Sounds like you landed on what the sample solution shows. I read through the lab commentary and saw that it didn’t overtly remind you to configure the VLANs (the sample config lists those commands, but the commentary does not.) I added a few words on that point in case that’s what was keeping you from finding the answer.
Many thanks sir! Always a great teacher! 🙂
Hello, is the no shutdown required for the interface VLANs? I mean, aren’t they enabled by default? (considering the fact that Dist1 & Dist2 know about those VLANs, and that they are allowed by default in the trunks).
Angel,
I agree, the VLAN interfaces will be “no shutdown” by default. I have seen some unusual cases in the past for which they were not, so I make a habit of doing a no shut on those. However, to the specifics as requested, and with our usual convention of not adding commands unless required, those are not needed.
Hello Grand Master,
great lab! one callout under > Lab Commentary:
“The PortChannel interface also needs to be configured as a routed port, and then it also needs an IPv4 address. To do so, use the interface port-channel 10 command to get into interface config mode and configure the IP address using the ip address 100.1.2.1 255.255.255.240 command. Then add the no switchport command to make the port-channel interface a routed port.”
… the sequence of the underlined texts should be transposed.
TY!
Hi Wendell,
Apart from the connected routes, are we meant to see OSPF-learnt routes in the routing table as well? If not, what was the purpose of OSPF being enabled?
Thanks,
Sam
Hey Sam,
Yes, I would expect the two layer 3 switches to learn OSPF routes in this lab.
I didn’t repeat the lab, but I keep a .pkt file with what I think is the completed config. I just opened it and it shows all the OSPF routes. So… OSPF troubleshooting exercise!
Check: Do the two distribution switches become neighbors? If not, check whether you can ping one to the other for the IP addresses on the L3 portchannel.
If yes, then I’d look at the two VLAN interfaces on each distribution switch. Are the VLAN interfaces up? EG, check “show ip ospf interface brief”, to show if OSPF is enabled there and also check the state.
Feel free to post again once you look into it.
Hey Wendell, I noticed a few other people having similar issues when attempting to make the port-channel a routed port. Now with PT version 8.2.2.0400, I get “Incomplete command.” when attempting to do so. I’m not sure if I’m missing something? I double checked with your configuration and it seems everything else is in order for this to work properly… Thanks for the invaluable resources!
Thought I would just give an update… as stated earlier it seems the no switchport command in an EtherChannel interface only works if the ports that were placed in there weren’t previously made into Layer 3 interfaces. Or vise versa. If you set them up as Layer 3 interfaces, place them in the port-channel, and then try the command you’ll get the error as per above. It seems PT automatically applies the “no switchport” command to the port-channel. Ultimately, the issue I was having was my own mistake. Sometimes taking a break helps!
Simon,
Thanks for the update!
I just configured some real switches to ensure the config here looks good. The automated adding on config can get in the way on real gear as well, for sure. Maybe stick with the “no shutdown” before setting up a port-channel approach to remove some of the issues.
Great to know that you got it to work in the latest Packet Tracer! Woohoo!!!!
Your job: configure the SVIs (VLAN interfaces) necessary for routing the connected subnets on the access VLANs. The IP addresses on these SVIs will be used by the PCs in the network as their default gateway IP addresses
i thought we need to configure access switches with vlan interfaces and then got confused whats the point of distribution switches here then?
so we need to configure svis on d1 and d2 and here the access switches function as
layer 2 switches ?and the default gateways for the pcs will be d1 and d2 ?
Hi Sana,
In short: Your second paragraph is the correct conclusion.
Longer: The access switches are set up as layer 2 switches, so they have no knowledge of layer 3 actions. The design is relatively common, with the distribution layer switches acting as the layer 3 switches and as the default gateways.
Greetings Mr. Wendell!
Just wanted to share my experience regarding this “no switchport” command issue. I’m currently running PT version 8.2.2. So, after creating the ehterchannel under interface range mode, I moved into port-channel interface mode (int PO10) to configure the IP address/mask, and this is where the issue occured. IOS accepts the IP address/mask commands normally, but when you add the “no switchport” command, it says “incomplete command”. (Previously when in interface range mode however, the “no switchport” command was accepted, thus successfully creating routed ports) Even though in port-channel int mode the command was not accepted (or incomplete per IOS), when I ran the show running config command, the “no switchport” command was displayed together with the IP address commands under the Port-channel interface config. It seems that PT just adds the command automatically when the channel is created while in interface range mode. (Similarly like IOS automatically adding the “no ip address” to the config when the “no switchport” command is entered.) Thanks again another great and fun lab!
Hi Mizael,
Thanks much for the post! yeah, I know real switches all some of the config, e.g., the “no IP address” command after you configure “no switchport”. I can’t imagine working on the Cisco Packet Tracer team and making sure all those particulars match the real thing in every case. I’ll see if I can summarize it in a meaningful way in the CPT issues tab. Thanks for the heads up.
You’re welcome, and glad you like the labs!! 🙂