Config Lab: Syslog 2

 In 200-301 V2 Ch09: Device Management, 200-301 V2 Part 3: IP Services, 200-301 V2 Parts, Config Lab, Config Lab CCNA Vol 2 Part 3, Hands-on

Most of us skim through descriptions of Syslog messages and message levels. This lab helps you slow down just a bit with a configuration exercise that makes you remember message severity levels and how to configure them. As usual, the lab should take you 5-10 minutes to read and type in a sample configuration if you remember most of what to do. Then you can try it in Cisco Packet Tracer or Cisco Modeling Labs. Enjoy!

All about Config Labs

The blog has a series of lab exercises called “Config Labs.” Each lab presents a topology with the relevant initial configuration for each device. The lab also lists new requirements, after which you should create the additional configuration to meet those requirements. You can do the lab on paper, in a text editor, or use software tools like Cisco Packet Tracer or Cisco Modeling Labs.

Once you have created your answer, you can click various tabs at the bottom of this post to see the lab answers, comments about the lab, and other helpful information.

The Lab Exercise

The Lab Requirements

In this lab, you will enable system logging with a couple of different conventions. and change the message format in a couple of ways on both routers. The specific rules for this lab are:

  • Send all Emergency, Alert, and Critical Syslog Messages to the Syslog server. When configuring the command:
    • On R1, refer to the message levels by name
    • On R2, refer to the message levels by number
  • Use the Syslog server shown in the figure
  • Disable all local device logging except console logging

 

Figure 1: Two Routers with IP Addresses

 

Initial Configuration

Examples 1 and 2 show the beginning configuration state of R1 and R2.

hostname R1
!
interface GigabitEthernet0/1
 ip address 172.30.180.193 255.255.255.252
 no shutdown
!
interface GigabitEthernet0/2
 no shutdown
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

Example 1: R1 Config

 

hostname R2
!
interface GigabitEthernet0/1
 ip address 10.10.10.1 255.255.255.0
 no shutdown
!
interface GigabitEthernet0/2
 ip address 172.30.180.194 255.255.255.252
 no shutdown
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

Example 2: R2 Config

Answer Options - Click Tabs to Reveal

You can learn a lot and strengthen real learning of the topics by creating the configuration – even without a router or switch CLI. In fact, these labs were originally built to be used solely as a paper exercise!

To answer, just think about the lab. Refer to your primary learning material for CCNA, your notes, and create the configuration on paper or in a text editor. Then check your answer versus the answer post, which is linked at the bottom of the lab, just above the comments section.

You can also implement the lab using the Cisco Packet Tracer network simulator. With this option, you use Cisco’s free Packet Tracer simulator. You open a file that begins with the initial configuration already loaded. Then you implement your configuration and test to determine if it met the requirements of the lab.

(Use this link for more information about Cisco Packet Tracer.)

Use this workflow to do the labs in Cisco Packet Tracer:

  1. Download the .pkt file linked below.
  2. Open the .pkt file, creating a working lab with the same topology and interfaces as the lab exercise.
  3. Add your planned configuration to the lab.
  4. Test the configuration using some of the suggestions below.

Download this lab’s Packet Tracer File

You can also implement the lab using Cisco Modeling Labs – Personal (CML-P). CML-P (or simply CML) replaced Cisco Virtual Internet Routing Lab (VIRL) software in 2020, in effect serving as VIRL Version 2.

If you prefer to use CML, use a similar workflow as you would use if using Cisco Packet Tracer, as follows:

  1. Download the CML file (filetype .yaml) linked below.
  2. Import the lab’s CML file into CML and then start the lab.
  3. Compare the lab topology and interface IDs to this lab, as they may differ (more detail below).
  4. Add your planned configuration to the lab.
  5. Test the configuration using some of the suggestions below.

Download this lab’s CML file!

 

Network Device Info:

The CML topology matches the lab topology.

Lab Answers Below: Spoiler Alert

Lab Answers: Configuration (Click Tab to Reveal)

Answers

Figure 1: Two Routers with IP Addresses

no logging buffered
!
logging host 10.10.10.100
logging trap critical

Example 3: R1 Config

 

no logging buffered 
!
logging host 10.10.10.100
logging trap 2

Example 4: R2 Config

Commentary, Issues, and Verification Tips (Click Tabs to Reveal)

Commentary

Syslog provides a mechanism on devices to log the messages that a specific device (system) will typically generate to the console. This provides engineers with the ability to look back at the history of device and the view the events that have happened to gain insight as to its current status. This mechanism accounts for Syslog’s widespread use in troubleshooting. It also provides a method of delivering these messages to an external Syslog server for central storage.

The first requirement asked you to log to a syslog server at address 10.10.10.100. Both routers use the same command to do this: the logging host 10.10.10.100 global command.

Another requirement asks you to disable all local logging except for console messaging local logging. Local logging can be divided into two categories: console logging and buffered logging, disabled by the no logging console or no logging buffered global commands, respectively. Console logging is enabled by default, but the logging console command would be the correct command to re-enable it if it had been disabled.

The third requirement asked you to limit the level of messages to log. The logging trap level command limits the severity level of log messages, with all levels at the listed level, and more severe, sent to syslog. The requirements mentioned the most severe levels in order: Emergency (Level 0), Alert (Level 1) and Critical (Level 2) messages. As a result, both routers use the logging trap critical command. Because the critical level is also level 2, the command logging trap 2 could also be used. Check out chapter the management protocols chapter of the ICND1 Cert Guide for more details about syslog.

Known Issues in this Lab

This section of each Config Lab Answers post hopes to help with those issues by listing any known issues with Packet Tracer related to this lab. In this case, the issues are:

# Summary Detail
1 Limited support for the logging trap config command. On real gear, the logging trap message-level command allows the configuration of any of the eight message levels by name or number. CPT supports only the debugging level (level 7.)

 

Why Would Cisco Packet Tracer Have Issues?

(Note: The below text is the same in every Config Lab.)

Cisco Packet Tracer (CPT) simulates Cisco routers and switches. However, CPT does not run the same software that runs in real Cisco routers and switches. Instead, developers wrote CPT to predict the output a real router or switch would display given the same topology and configuration – but without performing all the same tasks, an actual device has to do. On a positive note, CPT requires far less CPU and RAM than a lab full of devices so that you can run CPT on your computer as an app. In addition, simulators like CPT help you learn about the Cisco router/switch user interface – the Command Line Interface (CLI) – without having to own real devices.

CPT can have issues compared to real devices because CPT does not run the same software as Cisco devices. CPT does not support all commands or parameters of a command. CPT may supply output from a command that differs in some ways from what an actual device would give. Those differences can be a problem for anyone learning networking technology because you may not have experience with that technology on real gear – so you may not notice the differences. So this section lists differences and issues that we have seen when using CPT to do this lab.

Beyond comparing your answers to this lab’s Answers post, you can test in Cisco Packet Tracer (CPT) or Cisco Modeling Labs (CML). In fact, you can and should explore the lab once configured. For this lab, once you have completed the configuration, try these verification steps. 

  1. To test the effects of your configuration, login from the console and then get into config mode and back out again. Each time the router will issue a log message to the console, proving the default setting per the logging console command.
  2. Issue the show logging command both before and after you disable the buffering of log messages. Before, you should see a dozen or so descriptive lines, plus the list of log messages. Afterward, you should see only the descriptive lines, and no log messages. One of the descriptions at that point should state that Buffer logging is disabled.

More Labs with Related Content!

Config Lab: Syslog 1
Config Lab: Syslog 3
Subscribe
Notify of
guest

7 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Jonas

Are we supposed to disable the logging monitor as well using “no logging monitor”?

certskills

Hi Jonas,
I re-read the lab, and I agree – adding “no logging monitor” would be more complete, given the wording. Thanks for the heads up!
Wendell

Bill

As a follow-up to this one, is no logging buffered necessary? Is this one enabled by default, and if it’s not, would we need to disable it?

Bill

Hi Wendell – is the “host” term optional or mandatory for this command? I thought I saw in an example the book the command without the word “host”

ERMUNDO C RUSSELL

Hey Wendell,

Per your  Reply to  Jonas
 September 27, 2022 1:22 pm

about adding the “no logging monitor” command making the lab more complete CPT does not support the command at this time.

R2(config)#no logging ?
A.B.C.D IP address of the logging host
buffered Set buffered logging parameters
console Set console logging parameters
host Set syslog server IP address and parameters
on Enable logging to all enabled destinations
trap Set syslog server logging level
userinfo Enable logging of user info on privileged mode enabling

7
0
Would love your thoughts, please comment.x
()
x