Config Lab: L2 EtherChannel 1

 In 200-301 V1 Ch10: RSTP and EtherChannel, 200-301 V1 Part 3: VLANs, STP, 200-301 V1 Parts, Config Lab, Config Lab CCNA Vol 1 Part 3, Hands-on

EtherChannel takes a big step towards improving STP. With two links between switches, but without using EtherChannel, each instance of STP could use only one of the links blocking the other link. With a layer 2 EtherChannel, STP treats the links as one, balancing the traffic over the links when in a forwarding state. This next lab takes a quick and easy look at Layer 2 EtherChannel Config.

All about Config Labs

The blog has a series of lab exercises called “Config Labs.” Each lab presents a topology with the relevant initial configuration for each device. The lab also lists new requirements, after which you should create the additional configuration to meet those requirements. You can do the lab on paper, in a text editor, or use software tools like Cisco Packet Tracer or Cisco Modeling Labs.

Once you have created your answer, you can click various tabs at the bottom of this post to see the lab answers, comments about the lab, and other helpful information.

The Lab Exercise

Requirements

In this lab, you practice the various options to enable a Layer 2 EtherChannel on a Cisco switch. The variety of requirements listed here are used just to exercise all the options. In particular:

  • Use these EtherChannel Numbers:
    • 20 between SW1 and SW2
    • 21 between SW1 and SW3
    • 22 between SW2 and SW4
  • Configure for the following requirements:
    • EC 20: statically enable on both ends.
    • EC 21: use PAgP, with SW1 initiating the EC and SW3 waiting for SW1.
    • EC 22: use LACP, with SW2 initiating the EC and SW4 waiting for SW2.
  • The switches have all default configuration except for their hostnames.

Figure 1: Three EtherChannels, with Two Links Each

 

Initial Configuration

While you might be able to configure EtherChannel based on the information supplied so far, the initial configurations of the three switches can also be helpful. Examples 1 and 2 show the beginning configuration state of SW1 and SW2.

hostname SW1
!
interface GigabitEthernet1/0/1
 no shutdown
!
interface GigabitEthernet1/0/2
 no shutdown 
!
interface GigabitEthernet1/0/3
 no shutdown
!
interface GigabitEthernet1/0/4
 no shutdown 
!
interface GigabitEthernet1/0/10
 no shutdown
 switchport mode access

Example 1: SW1 Config

 

hostname SW2
!
interface GigabitEthernet1/0/1
 no shutdown
!
interface GigabitEthernet1/0/2
 no shutdown
!
interface GigabitEthernet1/0/3
 no shutdown
!
interface GigabitEthernet1/0/4
 no shutdown
! 
interface GigabitEthernet1/0/10 
  no shutdown
  switchport mode access

Example 2: SW2 Config

 

hostname SW3
!
interface GigabitEthernet1/0/1
 no shutdown
!
interface GigabitEthernet1/0/2
 no shutdown 

Example 3: SW3 Config

 

hostname SW4
!
interface GigabitEthernet1/0/1
 no shutdown
!
interface GigabitEthernet1/0/2
 no shutdown

Example 4: SW4 Config

Answer Options - Click Tabs to Reveal

You can learn a lot and strengthen real learning of the topics by creating the configuration – even without a router or switch CLI. In fact, these labs were originally built to be used solely as a paper exercise!

To answer, just think about the lab. Refer to your primary learning material for CCNA, your notes, and create the configuration on paper or in a text editor. Then check your answer versus the answer post, which is linked at the bottom of the lab, just above the comments section.

You can also implement the lab using the Cisco Packet Tracer network simulator. With this option, you use Cisco’s free Packet Tracer simulator. You open a file that begins with the initial configuration already loaded. Then you implement your configuration and test to determine if it met the requirements of the lab.

(Use this link for more information about Cisco Packet Tracer.)

Use this workflow to do the labs in Cisco Packet Tracer:

  1. Download the .pkt file linked below.
  2. Open the .pkt file, creating a working lab with the same topology and interfaces as the lab exercise.
  3. Add your planned configuration to the lab.
  4. Test the configuration using some of the suggestions below.

Download this lab’s Packet Tracer File

You can also implement the lab using Cisco Modeling Labs – Personal (CML-P). CML-P (or simply CML) replaced Cisco Virtual Internet Routing Lab (VIRL) software in 2020, in effect serving as VIRL Version 2.

If you prefer to use CML, use a similar workflow as you would use if using Cisco Packet Tracer, as follows:

  1. Download the CML file (filetype .yaml) linked below.
  2. Import the lab’s CML file into CML and then start the lab.
  3. Compare the lab topology and interface IDs to this lab, as they may differ (more detail below).
  4. Add your planned configuration to the lab.
  5. Test the configuration using some of the suggestions below.

Download this lab’s CML file!

 

Network Device Info:

This lab happens to use some interface numbers that cannot be replicated in CML. The .YAML file supplied here translates the lab to use the ports listed in the following table.

Device Lab Port CML Port
SW1 G1/0/1 G0/1
SW1 G1/0/2 G0/2
SW1 G1/0/3 G1/1
SW1 G1/0/4 G1/2
SW1 G1/0/10 G0/3
SW2 G1/0/1 G0/1
SW2 G1/0/2 G0/2
SW2 G1/0/3 G1/1
SW2 G1/0/4 G1/2
SW2 G1/0/10 G0/3
SW3 G1/0/1 G0/1
SW3 G1/0/2 G0/2
SW4 G1/0/1 G0/1
SW4 G1/0/2 G0/2

 

Host device info:

This table lists host information pre-configured in CML, information that might not be required by the lab but may be useful to you.

Device IP Address Mac Address User/password
PC1 172.16.1.1/24 02:00:11:11:11:11 cisco/cisco
PC2 172.16.1.2/24 02:00:22:22:22:22 cisco/cisco

Lab Answers Below: Spoiler Alert

Lab Answers: Configuration (Click Tab to Reveal)

Figure 1: Three EtherChannels, with Two Links Each

Answers

interface GigabitEthernet1/0/1
 channel-group 20 mode on
!
interface GigabitEthernet1/0/2
 channel-group 20 mode on
!
interface GigabitEthernet1/0/3
 channel-group 21 mode desirable
!
interface GigabitEthernet1/0/4
 channel-group 21 mode desirable

Example 5: SW1 Config

 

interface GigabitEthernet1/0/1
 channel-group 20 mode on
!
interface GigabitEthernet1/0/2
 channel-group 20 mode on
!
!
interface GigabitEthernet1/0/3
 channel-group 22 mode active
!
interface GigabitEthernet1/0/4
 channel-group 22 mode active

Example 6: SW2 Config

 

interface GigabitEthernet1/0/1
 channel-group 21 mode auto
!
interface GigabitEthernet1/0/2
 channel-group 21 mode auto

Example 7: SW3 Config

 

interface GigabitEthernet1/0/1
 channel-group 22 mode passive
!
interface GigabitEthernet1/0/2
 channel-group 22 mode passive

Example 8: SW4 Config

Commentary, Issues, and Verification Tips (Click Tabs to Reveal)

Commentary

Cisco uses the term EtherChannel to refer to their link aggregation technology. Link aggregation overcomes some of the shortcomings of the Spanning Tree Protocol (STP). For example, if EtherChannel was not being run on the links between SW1 and SW2, then one of the links would automatically be blocked by STP to ensure that a switching loop does not form; this will lose half of the available throughput. EtherChannel combines both links into a single logical link; because of this, STP considers this a single connection between the devices and does not block any of the ports.

Static EtherChannel configuration uses on mode per the channel-group mode interface subcommand; however, using this mode has the potential for causing problems. Both switches must use compatible settings on their links, and the dynamic methods to form a channel perform compatibility checks. Because of that, Cisco recommends using one of the dynamic protocols to negotiate the use of EtherChannel: Port Aggregation Protocol (PAgP) and Link Aggregation Control Protocol (LACP). PAgP is a Cisco proprietary version of link aggregation that was introduced before LACP. LACP is a standard-based solution and is defined in 802.3ad.

The lab asks for a variety of combinations to exercise your configuration skills. For EtherChannel 20, between SW1 and SW2, both interfaces on each switch need to be configured in on mode with the channel-group 20 mode on command.

For EtherChannel 21, between SW1 and SW3, SW1’s G1/0/3 and G1/0/4 use the channel-group 21 mode desirable command, which uses PAgP, and initiates the negotiation. SW3’s G1/0/1 and G1/0/2 use the channel-group 21 mode auto command, which uses PAgP, but passively waits for the other switch to initiate negotiations.

For EtherChannel 22, between SW2 and SW4, SW2’s G1/0/3 and G1/0/4 use the channel-group 22 mode active command, which uses LACP, and initiates the negotiation. SW4’s G1/0/1 and G1/0/2 use the channel-group 22 mode passive command, which uses LACP, but passively waits for the other switch to initiate negotiations.

Note that all the interfaces used default configuration, so there should be no mismatched interface settings preventing any interfaces from joining a Layer 2 EtherChannel. See the CCNA Official Cert Guides for more details on checking for those dependencies and for a broader look at EtherChannels.

Known Issues in this Lab

This section of each Config Lab Answers post hopes to help with those issues by listing any known issues with Packet Tracer related to this lab. In this case, the issues are:

# Summary Detail
1 None No known issues related to this lab.

 

Why Would Cisco Packet Tracer Have Issues?

(Note: The below text is the same in every Config Lab.)

Cisco Packet Tracer (CPT) simulates Cisco routers and switches. However, CPT does not run the same software that runs in real Cisco routers and switches. Instead, developers wrote CPT to predict the output a real router or switch would display given the same topology and configuration – but without performing all the same tasks, an actual device has to do. On a positive note, CPT requires far less CPU and RAM than a lab full of devices so that you can run CPT on your computer as an app. In addition, simulators like CPT help you learn about the Cisco router/switch user interface – the Command Line Interface (CLI) – without having to own real devices.

CPT can have issues compared to real devices because CPT does not run the same software as Cisco devices. CPT does not support all commands or parameters of a command. CPT may supply output from a command that differs in some ways from what an actual device would give. Those differences can be a problem for anyone learning networking technology because you may not have experience with that technology on real gear – so you may not notice the differences. So this section lists differences and issues that we have seen when using CPT to do this lab.

Beyond comparing your answers to this lab’s Answers post, you can test in Cisco Packet Tracer (CPT) or Cisco Modeling Labs (CML). In fact, you can and should explore the lab once configured. For this lab, once you have completed the configuration, try these verification steps. 

  1. Verifying EtherChannel takes just a quick look at the output from the show etherchannel number summary command. This command should list all the ports in the working EtherChannel with a status of P, meaning the port is in the channel.
  2. Troubleshooting why a port is not in the EtherChannel requires more effort, such as checking the variety of interface settings that must match on one switch, and on neighboring switches, before a switch will form the channel and add all ports to it. See the CCNA Official Cert Guide, Volume 1, section  “Troubleshooting EtherChannel” section for more details.

More Labs with Related Content!

Config Lab: RSTP Config 2
Config Lab: L2 EtherChannel 2
Subscribe
Notify of
guest

14 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Chris

Example 8? switch 4 config. I don’t think this is typed properly.

certskills

Examples 1-4 show the initial config to begin the lab. Examples 5-8, in the answers section, show the answers. I numbered each example with a unique number. So it’s purposeful.

Roger

Can we do ‘test etherchannel load-balance ….’ CLI same as in the book ?

certskills

Roger,
You can if you have a real Cisco switch that supports the command. However, I’m sure Cisco Packet Tracer does not support it. I do not know about CML, GNS3, or EVE-ng, but typically the switch images in those virtualization tools do not support commands that display info about what the hardware does, eg, host the ASIC balances frames on an EtherChannel. For example, I used 2960XR switches when creating the output in the book. Hope this helps.
Wendell

GJM

Just fyi PT doesn’t recover from an EtherChannel err-disabled state if you enter interface configuration mode on the actual port-channel and type shut/no shut. You have to do it from the physical port line configuration mode.

Emma

Minor nitpick, but it looks like the interface names in the answer configurations don’t match those in the diagram.

ERMUNDO C RUSSELL

Hey Wendell. I tried to use the verification tip for CPT (show etherchannel number summary) command does not work in CPT at least not in the CPT version I am using. Show etherchannel, and show etherchannel summary works well so far. I didn’t see this error in the “known packet tracer issues” tab. After verifying you may want to drop this error in there.

Just FYI.

Tewa

Hello Wendell,

Please some clarification questions:
I configured the link between SW1 & SW2 manually as per the requirement with the mode on command. When I issued the show etherchannel port-channel command, I noticed that output for Po20 shows PAGP as the protocol. Is that the default setting in IOS to use PAGP when etherchannel is manually set?

SW1#show etherchannel port-channel
Channel-group listing:
———————-

Group: 20
———-
Port-channels in the group:
—————————

Port-channel: Po20
————

Age of the Port-channel = 00d:00h:02m:59s
Logical slot/port = 2/20 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel
Protocol = PAGP
Port Security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits
——+——+——+——————+———–
0 00 Gig1/0/1 On 0
0 00 Gig1/0/2 On 0
Time since last port bundled: 00d:00h:02m:59s Gig1/0/2
Group: 21
———-
Port-channels in the group:
—————————

Port-channel: Po21
————

Age of the Port-channel = 00d:00h:01m:49s
Logical slot/port = 2/21 Number of ports = 0
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel
Protocol = PAGP
Port Security = Disabled

James Creel

This is sort of going away from this Lab but is totally about EtherChannel configuration and what your cert Guide states about it.

Key Topic on page 252 list ‘STP interface settings’ as one of the ‘items the switch checks’ before adding the new link to the channel.

It then turns around and states “When checking neighbors, all settings except the STP settings must match’

It then Proceeds by giving an example where “SW1’s G0/2 interface was given a different RSTP port cost than G0/1.” It then goes on to show how G0/1 and G0/2 were disabled and did not become active members of the EtherChannel.

I suppose I want to know which STP interface setting will and which will not prevent interfaces from joining or becoming active members of a EtherChannel?

Jay

Is it alright to use “int range g1/0/1-2” instead of setting channel-group to “on” individually for both ports?

14
0
Would love your thoughts, please comment.x
()
x