Config Lab: IPv6 Special Addresses 1

 In 200-301 V1 Ch24: Configure IPv6 Addressing, 200-301 V1 Part 7: IPv6, 200-301 V1 Parts, Config Lab, Config Lab CCNA Vol 1 Part 7, Hands-on

This latest config lab takes a backwards approach to configuration. In this case, it starts with a bunch of show commands, and asks you to derive some of the key configuration items on several routers. The theme: IPv6 addressing. By doing this lab, you will need to think hard about the unicast and multicast addresses listed in the output of the show ipv6 interface command.

All about Config Labs

The blog has a series of lab exercises called “Config Labs.” Each lab presents a topology with the relevant initial configuration for each device. The lab also lists new requirements, after which you should create the additional configuration to meet those requirements. You can do the lab on paper, in a text editor, or use software tools like Cisco Packet Tracer or Cisco Modeling Labs.

Once you have created your answer, you can click various tabs at the bottom of this post to see the lab answers, comments about the lab, and other helpful information.

The Lab Exercise

Requirements

This lab begins with a partially-complete configuration. It has some IPv6 configuration, but it is missing some. Your job is as follows:

  • Predict the IPv6 configuration required on each router that would result in the output in the show commands of Examples 1 through 5.
  • To test your answer, add your predicted config to the Packet Tracer file supplied with this lab, and then issue the same show commands. Compare the output in this lab post to what you see in Packet Tracer.
  • The answers below show the config that you would need to add so that the show commands will produce the output shown.

For this lab, you can make these assumptions:

  • All router interfaces shown in the lab are up and working.
  • IPv6 routing (ipv6 unicast-routing) is enabled
  • The figure shows the planned IPv6 subnets, with plans to use OSPF process 10 on all routers and area 0 throughout the design. However, some of those features may not as of yet be configured.

Figure 1: Three Router Topology

 

R1# show ipv6 interface gigabitEthernet0/1
GigabitEthernet0/1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FE40:C875 
  No Virtual link-local address(es):
  Global unicast address(es):
    2122::1, subnet is 2122::/64 
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF00:1
    FF02::1:FF40:C875
  MTU is 1500 bytes
! Lines omitted for brevity

Example 1: R1 Gi0/1 interface

 

R2# show ipv6 interface gigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FEF6:3364 
  No Virtual link-local address(es):
  Global unicast address(es):
    2223::F816:3EFF:FEF6:3364, subnet is 2223::/64 [EUI]
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FFF6:3364
  MTU is 1500 bytes
! Lines omitted for brevity

Example 2: R2 Gi0/1 interface

 

R2# show ipv6 interface gigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FE2C:AFCB 
  No Virtual link-local address(es):
  Global unicast address(es):
    2122::F816:3EFF:FE2C:AFCB, subnet is 2122::/64 [EUI]
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF2C:AFCB
  MTU is 1500 bytes
! Lines omitted for brevity

Example 3: R2 Gi0/2 interface

 

R3# show ipv6 interface gigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FEAE:9EA9 
  No Virtual link-local address(es):
  Global unicast address(es):
    3000::F816:3EFF:FEAE:9EA9, subnet is 3000::/64 [EUI]
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FFAE:9EA9
  MTU is 1500 bytes
! Lines omitted for brevity

Example 4: R3 Gi0/1 interface

 

R3# show ipv6 interface gigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FE0D:359F 
  No Virtual link-local address(es):
  Global unicast address(es):
    2223::2, subnet is 2223::/64 
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF00:2
    FF02::1:FF0D:359F
  MTU is 1500 bytes
! Lines omitted for brevity

Example 5: R3 Gi0/2 interface

 

Initial Configuration

Examples 6, 7, and 8 show the beginning configuration state of R1, R2, and R3.

 

hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255

Example 6: R1 Config

 

hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255

Example 7: R2 Config

 

hostname R3
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255

Example 8: R3 Config

Answer Options - Click Tabs to Reveal

You can learn a lot and strengthen real learning of the topics by creating the configuration – even without a router or switch CLI. In fact, these labs were originally built to be used solely as a paper exercise!

To answer, just think about the lab. Refer to your primary learning material for CCNA, your notes, and create the configuration on paper or in a text editor. Then check your answer versus the answer post, which is linked at the bottom of the lab, just above the comments section.

You can also implement the lab using the Cisco Packet Tracer network simulator. With this option, you use Cisco’s free Packet Tracer simulator. You open a file that begins with the initial configuration already loaded. Then you implement your configuration and test to determine if it met the requirements of the lab.

(Use this link for more information about Cisco Packet Tracer.)

Use this workflow to do the labs in Cisco Packet Tracer:

  1. Download the .pkt file linked below.
  2. Open the .pkt file, creating a working lab with the same topology and interfaces as the lab exercise.
  3. Add your planned configuration to the lab.
  4. Test the configuration using some of the suggestions below.

Download this lab’s Packet Tracer File

You can also implement the lab using Cisco Modeling Labs – Personal (CML-P). CML-P (or simply CML) replaced Cisco Virtual Internet Routing Lab (VIRL) software in 2020, in effect serving as VIRL Version 2.

If you prefer to use CML, use a similar workflow as you would use if using Cisco Packet Tracer, as follows:

  1. Download the CML file (filetype .yaml) linked below.
  2. Import the lab’s CML file into CML and then start the lab.
  3. Compare the lab topology and interface IDs to this lab, as they may differ (more detail below).
  4. Add your planned configuration to the lab.
  5. Test the configuration using some of the suggestions below.

Download this lab’s CML file!

 

Network Device Info:

The CML topology matches the lab topology.

Lab Answers Below: Spoiler Alert

Lab Answers: Configuration (Click Tab to Reveal)

Answers

Figure 1: Three Router Topology

 

The IPv6 Configuration that Existed at the Beginning of the Lab

Examples 1, 2, and 3 show the additional IPv6 configuration that existed in the configuration at the beginning of this lab.

interface GigabitEthernet0/1
 ipv6 address 2122::1/64
 no shutdown

Example 1: R1 Config

 

interface GigabitEthernet0/1
 ipv6 address 2223::/64 eui-64
 no shutdown
!
interface GigabitEthernet0/2
 ipv6 address 2122::/64 eui-64
 no shutdown

Example 2: R2 Config

 

interface GigabitEthernet0/1
 ipv6 address 3000::/64 eui-64
 no shutdown
!
interface GigabitEthernet0/2
 ipv6 address 2223::2/64
 no shutdown

Example 3: R3 Config

Commentary, Issues, and Verification Tips (Click Tabs to Reveal)

This lab takes a much different approach than the other Config Lab posts. How did you do?

To begin, open another window to the lab post, just so you can see the show ipv6 interface command output more easily. Pick any example command, and you will notice:

  1. On the 2nd line, a Link Local address (begins with FE80)
  2. A few lines below, a heading “Global Unicast Addresses”
  3. On the next line, one global unicast address

Now look hard at the last four quartets of each interface’s global unicast address versus the link local address. For each interface, those values are the same. When the router is configured with a global unicast address, it creates a matching link local address, copying the second half (last four quartets) from the global unicast address.

Next, scan Examples 1 through 5 in the lab post for the lines that list the global unicast addresses. Some list a notation of “EUI-64”, and some do not. Then compare that output to the topology figure. It just so happens that the initial configuration for this lab has some ipv6 address commands that use the eui-64 keyword, and some do not. (As a reminder, this keyword tells the router to derive the second half of the IPv6 address, rather than it being configured in the ipv6 address command.)

So, some conclusions you can reach from this analysis are:

  • Each interface listed in the lab’s Examples 1 through 5 have an ipv6 address command that configures an address.
  • These interfaces configure a prefix, along with the eui-64 parameter:
    • R2 G0/1
    • R2 G0/2
    • R3 G0/1
  • These interfaces configure the entire address, and do not include an eui-64 parameter:
    • R1 G0/1
    • R3 G0/2

Frankly, the above analysis is enough to know what was configured. The rest of the analysis explains the rest of the output, and also explains how you can know that OSPF has not yet been enabled.

Each router interface in the lab lists several supported multicast addresses. An interface needs either the ipv6 address command configured or an ipv6 enable command configured to enable IPv6 on the interface. Once enabled, the interface supports the following multicast IPv6 addresses, which happen to be listed on every interface in the lab:

  • FF02::1 – All nodes
  • FF02::2 – All routers

Next, each interface lists either one or two solicited node multicast addresses. These addresses begin with:

  • FF02::1:FF

The solicited node multicast address then ends with the same 6 hex digits as any unicast address on the interface (including link local addresses).

Note that IOS enables the FF02::1, FF02::2, and the appropriate solicited node multicast addresses automatically, without extra configuration, so there is no matching configuration to predict.

Finally, the lab stated that the intent was to use OSPFv3. However, OSPFv3 uses the following multicast addresses, which would be enabled on any interface on which OSPFv3 had been enabled:

  • FF02::5 – All OSPF routers
  • FF02::6 – All OSPF DRs and BDRs

Because these two multicast addresses are not listed on any of the interfaces shown in the lab, you can predict that OSPFv3 had not yet been configured.

Known Issues in this Lab

This section of each Config Lab Answers post hopes to help with those issues by listing any known issues with Packet Tracer related to this lab. In this case, the issues are:

# Summary Detail
1 Packet Tracer performs EUI-64 incorrectly when the 7th bit of the MAC is a 1. When performing the 7th-bit bit-flip, PT sets the 7th bit to 1, rather than flipping or inverting the bit. So, if the 7th bit of the MAC address is a 1, PT leaves the bit as a 1. A real Cisco router would flip the bit to 0.

 

Why Would Cisco Packet Tracer Have Issues?

(Note: The below text is the same in every Config Lab.)

Cisco Packet Tracer (CPT) simulates Cisco routers and switches. However, CPT does not run the same software that runs in real Cisco routers and switches. Instead, developers wrote CPT to predict the output a real router or switch would display given the same topology and configuration – but without performing all the same tasks, an actual device has to do. On a positive note, CPT requires far less CPU and RAM than a lab full of devices so that you can run CPT on your computer as an app. In addition, simulators like CPT help you learn about the Cisco router/switch user interface – the Command Line Interface (CLI) – without having to own real devices.

CPT can have issues compared to real devices because CPT does not run the same software as Cisco devices. CPT does not support all commands or parameters of a command. CPT may supply output from a command that differs in some ways from what an actual device would give. Those differences can be a problem for anyone learning networking technology because you may not have experience with that technology on real gear – so you may not notice the differences. So this section lists differences and issues that we have seen when using CPT to do this lab.

Beyond comparing your answers to this lab’s Answers post, you can test in Cisco Packet Tracer (CPT) or Cisco Modeling Labs (CML). In fact, you can and should explore the lab once configured. For this lab, once you have completed the configuration, try these verification steps. 

  1. When configuring, add just one IPv6 interface subcommand and then issue a show ipv6 interface command and look for the notes about unicast and multicast addresses.
  2. Continue to configure one interface at a time, and then repeat the show ipv6 interface command, until you get a sense for which configuration commands cause the various unicast and multicast addresses to appear in the show command output. 

More Labs with Related Content!

Config Lab: IPv6 Static Routes 2
Config Lab: IPv6 Special Addresses 2
Subscribe
Notify of
guest

14 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Flo

Hello grendal,

I hope all is well.

Wouldn’t R2 be interface GigabitEthernet0/2
ipv6 address 2122::/64 (without the eui-64) the figure does not mention eui-64?

Thank you

Isaac N.

Hello,

I configured OSPFv3 on each interface to test . The route tables have been properly updated, the Neighbor adjacencies is done with full state DR or BDR but I can’t see the multicast address FF02::6.

Actually I can see all multicast addresses mentioned in the answer except the multicast address for DR/BDR.

Is there a Packet Tracer issue or Am I one more time missing something?

thejackripper

all of these interfaces require a ‘mac-address’ command as the stored mac address has a second hex digit of 8 see for example:

R2:
GigabitEthernet0/2 is up, line protocol is up (connected)
Hardware is CN Gigabit Ethernet, address is f816.3e2c.afcb (bia 0060.4733.ae03)

which would end up with a link local of FE80::FA16:3EFF:FE2C:AFCB

so a ‘mac-address fa16.3e2c.afcb’ is needed to get the output shown in the problem of:

R2# show ipv6 interface gigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::F816:3EFF:FE2C:AFCB

this makes this problem a little confusing… at least with the given answer…

Vicente Torres

Yeah, i agree, the ‘mac-address fa16…’ commands should be included to reflect the inverted 7th bit of the mac address.

Lucas Wolf

Woah tuff stuff. Is OSPFv3 specific to CCNA exam? Thanks.

Tewa

Hello Wendell,

I am lost on this one, please I need more clarification on this lab. The only configuration I thought was missing on this lab is the OSPF configuration but I see you did not configure that in your answer instead you configured IPv6 addresses. Looking at the show commands, they listed IPv6 global unicast addresses for each interface on the topology and IPv6 routing is also enabled. My interepretation is that these have been configured or am I mistaken? Can the show command output the global unicast IPv6 address information if they were not already configured? I tried to do a show IPv6 int command and it came out blank. Thank you

Tewa

Thank you Wendell, now I understand.

Jeff

Either I have the wrong lab or something is wildly different. When I look at clab157 with no modifications at all, I see, for R2,

interface GigabitEthernet0/1
mac-address f816.3ef6.3364
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/2
mac-address f816.3e2c.afcb
no ip address
duplex auto
speed auto

There’s no way that configuration is going to generate the addresses show in the lab. I get it; I can configure the interfaces as shown in the lab, but they don’t appear to be there at the beginning.

14
0
Would love your thoughts, please comment.x
()
x