Config Lab: IPv6 Static Routes 3

Wendell Odom
By Wendell Odom September 28, 2021 17:05

Although this lab’s title is “IPv6 Static Routes 3”, it might be better called “Convoluted Fun with overlapping IPv6 Static Routes using Administrative Distance”. The purpose of the lab is to exercise a couple of specific ideas: how a router uses the most specific (that is, longest prefix) route to forward a packet, and how routers choose the routes with the best administrative distance.

All about Config Labs

The blog has a series of lab exercises called “Config Labs.” Each lab presents a topology with the relevant initial configuration for each device. The lab also lists new requirements, after which you should create the additional configuration to meet those requirements. You can do the lab on paper, in a text editor, or use software tools like Cisco Packet Tracer or Cisco Modeling Labs.

Once you have created your answer, you can click various tabs at the bottom of this post to see the lab answers, comments about the lab, and other helpful information.

The Lab Exercise

Requirements

First, to be clear: the design and requirements for this lab are not something you would do in a real network. But it works for understanding the concepts and commands.

The lab begins with routers R2, R3, R4, and R5 using EIGRP to learn IPv6 routes. For this exercise, R1 does not and will not use an IPv6 routing protocol. Instead, you will configure static routes as needed to overcome the lack of routing protocol on R1.

Your job for this lab is to configure static IPv6 routes on R1, with some admittedly strange requirements, all for the sake of getting a better understanding of what happens with overlapping IPv6 routes and administrative distance. The specific rules for this lab are:

  • Configure three static routes on router R1 for R5’s LAN subnet, as follows:
    • A route through R2 using an administrative distance of 50
    • A route through R3 using an administrative distance of 40
    • A route through R4 using an administrative distance of 60
  • Configure two overlapping static routes on router R1 that are host routes, as follows:
    • A static host route to PC2 through next-hop router R2 using an administrative distance of 100
    • A static host route to PC4 through R4 using an administrative distance of 110
  • Assumptions:
    • All router interfaces shown in the lab are up, working, and have correct IPv6 addresses assigned per the subnetting shown in the figure.
    • IPv6 routing is enabled on all routers.
    • All PCs have been configured with an IPv6 address, gateway, and are working.
    • Dynamic routing is enabled and working correctly for all appropriate prefixes for R2, R3, R4, and R5.

Figure 1: Router Triangle Topology

 

Initial Configuration

Examples 1, 2, 3, 4, and 5 show the beginning configuration state of R1, R2, R3, R4, and R5.

 

hostname R1
!
ipv6 unicast-routing
!
interface GigabitEthernet0/1
 ipv6 address 3000:1:2::1/64
 no shutdown
!
interface GigabitEthernet0/2
 ipv6 address 3000:1:3::1/64
 no shutdown
!
interface GigabitEthernet0/3
 ipv6 address 3000:1:4::1/64
 no shutdown

Example 1: R1 Config

 

hostname R2
!
ipv6 unicast-routing
!
interface GigabitEthernet0/1
 ipv6 address 3000:1:2::2/64
 ipv6 eigrp 10
 no shutdown
!
interface GigabitEthernet0/2
 ipv6 address 3000:2:5::1/64
 ipv6 eigrp 10
 no shutdown
!
ipv6 router eigrp 10
 eigrp router-id 2.2.2.2

Example 2: R2 Config

 

hostname R3
!
ipv6 unicast-routing
!
interface GigabitEthernet0/1
 ipv6 address 3000:1:3::2/64
 ipv6 eigrp 10
 no shutdown
!
interface GigabitEthernet0/2
 ipv6 address 3000:3:5::1/64
 ipv6 eigrp 10
 no shutdown
!
ipv6 router eigrp 10
 eigrp router-id 3.3.3.3

Example 3: R3 Config

 

hostname R4
!
ipv6 unicast-routing
!
interface GigabitEthernet0/1
 ipv6 address 3000:1:4::2/64
 ipv6 eigrp 10
 no shutdown
!
interface GigabitEthernet0/2/0
 ipv6 address 3000:4:5::1/64
 ipv6 eigrp 10
 no shutdown
!
ipv6 router eigrp 10
 eigrp router-id 4.4.4.4

Example 4: R4 Config

 

hostname R5
!
ipv6 unicast-routing
!
interface GigabitEthernet0/1
 ipv6 address 3000:2:5::2/64
 ipv6 eigrp 10
 no shutdown
!
interface GigabitEthernet0/2
 ipv6 address 3000:3:5::2/64
 ipv6 eigrp 10
 no shutdown
!
interface GigabitEthernet0/3
 ipv6 address 3000:4:5::2/64
 ipv6 eigrp 10
 no shutdown
!
interface GigabitEthernet0/4
 ipv6 address 2000::1/64
 ipv6 eigrp 10
 no shutdown
!
ipv6 router eigrp 10
 eigrp router-id 5.5.5.5

Example 5: R5 Config

Answer Options - Click Tabs to Reveal

You can learn a lot and strengthen real learning of the topics by creating the configuration – even without a router or switch CLI. In fact, these labs were originally built to be used solely as a paper exercise!

To answer, just think about the lab. Refer to your primary learning material for CCNA, your notes, and create the configuration on paper or in a text editor. Then check your answer versus the answer post, which is linked at the bottom of the lab, just above the comments section.

You can also implement the lab using the Cisco Packet Tracer network simulator. With this option, you use Cisco’s free Packet Tracer simulator. You open a file that begins with the initial configuration already loaded. Then you implement your configuration and test to determine if it met the requirements of the lab.

(Use this link for more information about Cisco Packet Tracer.)

Use this workflow to do the labs in Cisco Packet Tracer:

  1. Download the .pkt file linked below.
  2. Open the .pkt file, creating a working lab with the same topology and interfaces as the lab exercise.
  3. Add your planned configuration to the lab.
  4. Test the configuration using some of the suggestions below.

Download this lab’s Packet Tracer File

You can also implement the lab using Cisco Modeling Labs – Personal (CML-P). CML-P (or simply CML) replaced Cisco Virtual Internet Routing Lab (VIRL) software in 2020, in effect serving as VIRL Version 2.

If you prefer to use CML, use a similar workflow as you would use if using Cisco Packet Tracer, as follows:

  1. Download the CML file (filetype .yaml) linked below.
  2. Import the lab’s CML file into CML and then start the lab.
  3. Compare the lab topology and interface IDs to this lab, as they may differ (more detail below).
  4. Add your planned configuration to the lab.
  5. Test the configuration using some of the suggestions below.

Download this lab’s CML file!

 

Network Device Info:

This table lists the interfaces listed in the lab exercise documentation versus those used in the sample CML file.

Device Lab Port  CML Port
R4 G0/2/0 G0/2
R5 G0/3/0 G0/3

Host device info:

This table lists host information pre-configured in CML, information that might not be required by the lab but may be useful to you.

Device IP Address Mac Address User/password
PC1 2001::101/64 02:00:11:11:11:11 cisco/cisco
PC2 2001::102/64 02:00:22:22:22:22 cisco/cisco
PC3 2001::103/64 02:00:33:33:33:33 cisco/cisco
PC4 2001::104/64 02:00:44:44:44:44 cisco/cisco

Lab Answers Below: Spoiler Alert

Lab Answers: Configuration (Click Tab to Reveal)

Answers

Figure 1: Router Triangle Topology

 

ipv6 route 2000::102/128 3000:1:2::2 100
ipv6 route 2000::104/128 3000:1:4::2 110
ipv6 route 2000::/64 3000:1:4::2 60
ipv6 route 2000::/64 3000:1:3::2 40
ipv6 route 2000::/64 3000:1:2::2 50

Example 1: R1 Config

Commentary, Issues, and Verification Tips (Click Tabs to Reveal)

Commentary

This lab is focused with two primary goals in mind. First, to further practice in using IPv6 static routes to remote networks using both networks and host routes. Second, to highlight some of the differences in forwarding behavior when using multiple different administrative distances.

There are two major things you need to keep in mind when determining which route will be used to a network: First, is this the most specific route to the destination? Second, if so, does this route have the lowest administrative distance? Keep in mind that the order of these two questions is very important.

For this lab, you were tasked with configuring five different static IPv6 routes. Three of these routes offer different paths to R5’s LAN subnet. The requirements tell you to use three different administrative distances. Those three routes are:

  1. The first route to configure for R5’s LAN uses R2 as a next hop and an administrative distance of 50; the LAN between R1 and R2 uses the 3000:1:2::/64 network with R2 being configured with the 3000:1:2::2 address as the next hop address. The command to configure this route would be ipv6 route 2000::/64 3000:1:2::2 50.
  2. The second route to configure for R5’s LAN uses R3 as a next hop and an administrative distance of 40; the LAN between R1 and R3 uses the 3000:1:3::/64 network with R3 being configured with the 3000:1:3::2 address as the next hop address. The command to configure this route would be ipv6 route 2000::/64 3000:1:3::2 40.
  3. The third and final route to configure for R5’s LAN uses R4 as a next hop and an administrative distance of 60; the LAN between R1 and R4 uses the 3000:1:4::/64 network with R4 being configured with the 3000:1:4::2 address as the next hop address. The command to configure this route would be ipv6 route 2000::/64 3000:1:4::2 60.

Ask yourself at this point, which of these routes would be preferred when selecting a path from R1 to R5’s LAN?

The other two routes requested in for this lab are host routes for PC2 and PC4 which potentially alter the routing behavior of R1. The first was a host route for PC2 using R2 as a next hop and an administrative distance of 100. The command to configure this route would be ipv6 route 2000::102/128 3000:1:2::2 100. The second was a host route for PC4 using R4 as a next hop and an administrative distance of 110; the command to configure this route would be ipv6 route 2000::104/128 3000:1:4::2 110. Note that the use of the /128 prefix length is the IPv6 equivalent of using the 255.255.255.255 subnet mask.

Ask yourself now, will either of these host routes alter the routing behavior of traffic from R1 to PC2 and PC4? The answer is yes, this is because each of these routes will be more specific than the previous three routes for the 2000::/64 subnet. R5 only considers the administrative distance if the destination of the route is exactly the same.

The two host routes cause R5 to forward packet of those two hosts over those specific routes:

  • Traffic destined for PC2 will always go through R2 assuming the interface is still operational.
  • Traffic destined for PC4 will always go through R4 assuming that interface is still operational.

Just to complete the idea, Example 2 lists router R1’s routing table after adding the configuration in this lab. It shows only one of the three static routes to subnet 2000:://64, the one with 3000:1:3::2 as next hop, with administrative distance 40. Why? Because those three routes have the exact same destination (2000::/64), but different administrative distance values, so router R1 adds only the router that has the best AD. However, for the two host routes, the destination of each route is unique, so the AD values of 100 and 110 were not needed by R1 to choose between multiple static routes to the same destination.

R1# show ipv6 route static
IPv6 Routing Table - default - 12 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
S   2000::/64 [40/0]
     via 3000:1:3::2
S   2000::102/128 [100/0]
     via 3000:1:2::2
S   2000::104/128 [110/0]
     via 3000:1:4::2

Example 2: R1 IPv6 Routing Table

Known Issues in this Lab

This section of each Config Lab Answers post hopes to help with those issues by listing any known issues with Packet Tracer related to this lab. In this case, the issues are:

# Summary Detail
1 None No known issues related to this lab.

 

Why Would Cisco Packet Tracer Have Issues?

(Note: The below text is the same in every Config Lab.)

Cisco Packet Tracer (CPT) simulates Cisco routers and switches. However, CPT does not run the same software that runs in real Cisco routers and switches. Instead, developers wrote CPT to predict the output a real router or switch would display given the same topology and configuration – but without performing all the same tasks, an actual device has to do. On a positive note, CPT requires far less CPU and RAM than a lab full of devices so that you can run CPT on your computer as an app. In addition, simulators like CPT help you learn about the Cisco router/switch user interface – the Command Line Interface (CLI) – without having to own real devices.

CPT can have issues compared to real devices because CPT does not run the same software as Cisco devices. CPT does not support all commands or parameters of a command. CPT may supply output from a command that differs in some ways from what an actual device would give. Those differences can be a problem for anyone learning networking technology because you may not have experience with that technology on real gear – so you may not notice the differences. So this section lists differences and issues that we have seen when using CPT to do this lab.

Beyond comparing your answers to this lab’s Answers post, you can test in Cisco Packet Tracer (CPT) or Cisco Modeling Labs (CML). In fact, you can and should explore the lab once configured. For this lab, once you have completed the configuration, try these verification steps. 

  1. Move to the command prompt of each PC and ping the other PCs. All the pings should work.
  2. Use an extended ping command from each routers’ CLI to ping from a source router’s G0/2 interface IPv6 address to the other routers’ G0/2 interface IP addresses. For instance, from R1, the command ping 2004::1 source 2001::1 would test the forward route to R4’s G0/2 subnet and the reverse route back to R1’s G0/2 subnet.
  3. A more interesting test is to connect to router R1’s console and use the traceroute command to trace the path to the four PCs in succession (2000::101, 2000::102, 2000::103, and 2000::104). If you try that, focus on the first router in the list in each case; it should be the next hop router per the static route you just configured for the lab.

More Labs with Related Content!

Config Lab: IPv6 Static Routes 2
Config Lab: IPv6 Special Addresses 1
Wendell Odom
By Wendell Odom September 28, 2021 17:05
Subscribe
Notify of

Your e-mail address will not be published.
Required fields are marked*

guest

7 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Frank Wijmans
Frank Wijmans
February 16, 2022 10:02 am

Just to let you know Wendell, after I imported the lab file for CML, I noticed that all of the routers booted without any initial config.

Eventually this provided me with some extra practise on getting the initial config in there and getting the lab requirements done, that was fun 🙂

But you might want to check it out.

Cheers!

certskills
Admin
Reply to  Frank Wijmans
March 4, 2022 9:03 am

Frank,
Glad you enjoyed the workout! 🙂
I looked at the .yaml file for the lab (used by CML), and I agree, we forgot to place the initial configs for the routers. I’ve added it to the todo list. Thanks much.

Raed
Raed
March 1, 2022 4:18 pm

From configure three static routes on router R1 for exactly same subnet “prefix/length” the router will add route with lowest administrative distance to its IPV6 routing table.
and for configure two overlapping static routes the router will treat them as different subnet so in this case no consider to administrative distance, so both will add to R1’s IPV6 routing table

Thanks

certskills
Admin
Reply to  Raed
March 4, 2022 9:03 am

I concur! 🙂

Joe
Joe
June 13, 2022 9:06 pm

Really enjoyed this lab!

certskills
Admin
Reply to  Joe
June 16, 2022 5:14 pm

Thanks, Joe!

Tom
Tom
August 10, 2022 7:50 pm

Challenging lab. Really good practice.

Also, be aware the interfaces in the initial configurations listed above for R1 and R5 do not match the topology diagram. On R1, G0/3 should be G0/0 and on R5, G0/4 should be G0/0. The interfaces in the topology diagram do match the connected interfaces in the CML file.

Search

Categories