Config Lab: Interface PAT 1

 In 200-301 V2 Ch10: NAT, 200-301 V2 Part 3: IP Services, 200-301 V2 Parts, Config Lab, Config Lab CCNA Vol 2 Part 3, Hands-on

PAT – Port Address Translation – plays a huge role in IPv4 networks. Today’s post looks at the simpler of the two configuration options for router NAT configuration: a single router interface IP address as in the inside global address. Jump in for your next bit of 5-10 minutes of practice!

All about Config Labs

The blog has a series of lab exercises called “Config Labs.” Each lab presents a topology with the relevant initial configuration for each device. The lab also lists new requirements, after which you should create the additional configuration to meet those requirements. You can do the lab on paper, in a text editor, or use software tools like Cisco Packet Tracer or Cisco Modeling Labs.

Once you have created your answer, you can click various tabs at the bottom of this post to see the lab answers, comments about the lab, and other helpful information.

The Lab Exercise

Requirements

Configure PAT to support hosts in the subnet off R1’s G0/1 interface, for instance, for inside hosts like S1, S2, and S3. Use the following specific rules:

  • Match all inside addresses using a numbered ACL (ACL 1)
  • Use R1’s 10.20.30.1 IP address – it’s IP address on interface G0/2 – as the inside global address for all traffic that R1 translates with NAT/PAT
  • Configure static routes as needed on R2 so that R2 can forward packets back to these inside global addresses
  • Assume all router interfaces shown in the lab are up, working, and configured with IP addresses

Figure 1: PAT Topology

 

Initial Configuration

Examples 1 and 2 show the beginning configuration state of R1 and R2.

hostname R1
!
interface GigabitEthernet0/1
 ip address 172.100.100.1 255.255.255.0
 no shutdown
!
interface GigabitEthernet0/2
 ip address 10.20.30.1 255.255.255.252
 no shutdown

Example 1: R1 Config

 

hostname R2
!
interface GigabitEthernet0/1
 ip address 10.20.30.2 255.255.255.252
 no shutdown

Example 2: R2 Config

Answer Options - Click Tabs to Reveal

You can learn a lot and strengthen real learning of the topics by creating the configuration – even without a router or switch CLI. In fact, these labs were originally built to be used solely as a paper exercise!

To answer, just think about the lab. Refer to your primary learning material for CCNA, your notes, and create the configuration on paper or in a text editor. Then check your answer versus the answer post, which is linked at the bottom of the lab, just above the comments section.

You can also implement the lab using the Cisco Packet Tracer network simulator. With this option, you use Cisco’s free Packet Tracer simulator. You open a file that begins with the initial configuration already loaded. Then you implement your configuration and test to determine if it met the requirements of the lab.

(Use this link for more information about Cisco Packet Tracer.)

Use this workflow to do the labs in Cisco Packet Tracer:

  1. Download the .pkt file linked below.
  2. Open the .pkt file, creating a working lab with the same topology and interfaces as the lab exercise.
  3. Add your planned configuration to the lab.
  4. Test the configuration using some of the suggestions below.

Download this lab’s Packet Tracer File

You can also implement the lab using Cisco Modeling Labs – Personal (CML-P). CML-P (or simply CML) replaced Cisco Virtual Internet Routing Lab (VIRL) software in 2020, in effect serving as VIRL Version 2.

If you prefer to use CML, use a similar workflow as you would use if using Cisco Packet Tracer, as follows:

  1. Download the CML file (filetype .yaml) linked below.
  2. Import the lab’s CML file into CML and then start the lab.
  3. Compare the lab topology and interface IDs to this lab, as they may differ (more detail below).
  4. Add your planned configuration to the lab.
  5. Test the configuration using some of the suggestions below.

Download this lab’s CML file!

Network Device Info:

The CML topology matches the lab topology.

Lab Answers Below: Spoiler Alert

Lab Answers: Configuration (Click Tab to Reveal)

Answers

 

Figure 1: PAT Topology

 

interface GigabitEthernet0/1
 ip nat inside
!
interface GigabitEthernet0/2
 ip nat outside
!
ip nat inside source list 1 interface GigabitEthernet0/2 overload
!
access-list 1 permit 172.100.100.0 0.0.0.255

 Example 3: R1 Config

Commentary, Issues, and Verification Tips (Click Tabs to Reveal)

Commentary

There are several ways to configure NAT, including static NAT, dynamic NAT, and Port Address Translation (PAT). Static NAT is typically used for one-to-one translations from a specific inside address (called an inside local address) to a specific outside address (called an inside global address). Dynamic NAT differs slightly because it allocates the outside address from a configured pool rather than pre-determining the specific address to use in each case. The third major type of NAT, PAT (or NAT overload), uses either a specific outside address or a configured pool.

The difference between PAT and the other types is that the mapping is not one-to-one from an inside address to an outside address. With PAT, there is a many-to-one mapping between the inside local address and the inside global address using unique TCP and UDP port numbers to decide where and how to translate the packets.

For this lab, you were tasked with configuring PAT using R1’s G0/2 interface IP address for translations and access list 1. The ACL should match only R1’s LAN connecting to S1, S2, and S3. Once this is configured, the last step is to configure a PAT statement to use R1’s G0/2 interface and the ACL to map entries from R1’s LAN to its interface IP address.

First, you have to determine which interface(s) connect to hosts inside the network and connect to hosts outside the network. For this lab, R1’s G0/1 interface is connected to S1, S2, and S3 and is considered the inside interface. To configure this, use the ip nat inside command while in interface configuration mode. R1’s G0/2 interface is connected to R2 and is considered the outside interface. To configure this, use the ip nat outside command while in interface configuration mode.

The second task to perform is to configure the ACL to match R1’s LAN connecting to S1, S2, and S3, all in subnet 172.100.100.0/24. The global command access-list 1 permit 172.100.100.0 0.0.0.255 configures the entire ACL.

The third and final task uses one long command that ties four ideas together:

  1. Packets entering interfaces (per the source keyword)
  2. Packets matching the logic in ACL 1
  3. To use  one inside global address – the address of the G0/2 interface
  4. To use the PAT (overload) feature

The command: ip nat inside source list 1 interface GigabitEthernet0/2 overload.

Also, note that the requirements tell you to configure static routes on R2 as needed for the inside global addresses. In this case, the configuration uses a range of addresses in the subnet between R1 and R2, so R2 already has a connected route that includes the addresses used by NAT. So there is no need for any additional static routes.

Known Issues in this Lab

This section of each Config Lab Answers post hopes to help with those issues by listing any known issues with Packet Tracer related to this lab. In this case, the issues are:

# Summary Detail
1 Occasional incorrect NAT show command output based on sequencing CPT may show incorrect NAT behavior if you configure NAT and then move directly to testing. You might want to configure, then save and re-open the .pkt file before testing.

 

Why Would Cisco Packet Tracer Have Issues?

(Note: The below text is the same in every Config Lab.)

Cisco Packet Tracer (CPT) simulates Cisco routers and switches. However, CPT does not run the same software that runs in real Cisco routers and switches. Instead, developers wrote CPT to predict the output a real router or switch would display given the same topology and configuration – but without performing all the same tasks, an actual device has to do. On a positive note, CPT requires far less CPU and RAM than a lab full of devices so that you can run CPT on your computer as an app. In addition, simulators like CPT help you learn about the Cisco router/switch user interface – the Command Line Interface (CLI) – without having to own real devices.

CPT can have issues compared to real devices because CPT does not run the same software as Cisco devices. CPT does not support all commands or parameters of a command. CPT may supply output from a command that differs in some ways from what an actual device would give. Those differences can be a problem for anyone learning networking technology because you may not have experience with that technology on real gear – so you may not notice the differences. So this section lists differences and issues that we have seen when using CPT to do this lab.

Beyond comparing your answers to this lab’s Answers post, you can test in Cisco Packet Tracer (CPT) or Cisco Modeling Labs (CML). In fact, you can and should explore the lab once configured. Once you have completed the configuration, try these verification steps for this lab. 

  1. Verify the dynamic PAT configuration by checking the reachability from S1, S2, and S3 to R2 using ping.
    1. At router R1, use the show ip nat translations command to verify that the NAT table begins with no entries.
    2. From S1/S2/S3, try the ping 10.20.30.2 command, pinging R2’s global address, which tests the static NAT configuration.
    3. At router R1, the show ip nat translations command was used to verify a new NAT table entry that appeared in support of each flow.
    4. Pay close attention to the port numbers used and the fact that all translation table entries use the same outside global address with different port numbers.
  2. Use a TCP or UDP app to test from S1/S2/S3 to router R2. For instance, use Telnet.
    1. Because the initial configuration did not prepare router R2 for inbound Telnet, add configuration on R2 as follows:
      • line vty 0 15
      • transport input all
      • login
      • password cisco
    2. From S1/S2/S3, try the telnet 10.20.30.2 command, connecting to R2’s global address, which tests the dynamic NAT configuration.
    3. At router R1, the show ip nat translations command was used to verify a new NAT table entry that appeared in support of each flow.

More Labs with Related Content!

Config Lab: Dynamic NAT 1
Config Lab: Pat w/ a Pool 1
Subscribe
Notify of
guest

1 Comment
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Johannes K.

Hello,

The third requirement is not needed because subnet 10.20.30.0 is already know by R2.

Since the third requirement is not found in the answer, let’s forget about it.

ERMUNDO C RUSSELL

Hey Wendell,

The verification tips ask you to ping 172.16.10.2 R2’s global address. The problem is R2’s address is private at 10.20.30.2. It looks like the verification tips are a duplicate of the Dynamic NAT 1 config lab just before this PAT lab. R2 is also directly connected to R1 so the third requirement in the instructions is not needed as noted by Johannes K. previously. Just FYI.

1
0
Would love your thoughts, please comment.x
()
x