Answers: RIPv2 Basics 1

certskills
By certskills May 26, 2016 09:10

For this lab, your job is to take a working IPv4 network that has no routing protocol yet and add the RIPv2 configuration. As usual, check out the lab requirements here and take your shot at the configuration. Then check your answers here vs. my suggested answer.

Answers

Figure 1: Router Triangle Topology

 

Example 1: R1 Config

 

Example 2: R2 Config

 

Example 3: R3 Config

 

Commentary

Two fundamental duties of any network engineer will involve the configuration of IP addresses on routers and the configuration of a routing protocol. RIP is one of the simplest routing protocols to understand which is why it is often taught to new network engineers.

For this lab you were tasked with configuring RIP to ensure that each of the routers had reachability to all of these subnets in a simple design.

The requirements can be broken down into two broad categories: the commands used to enable RIP on router interfaces (using the network command), and any other commands related to RIP.

Covering the related commands first, one requirement stated that the routers should use RIP Version 2 and RIP Version 2 only. To do that, simply configure each RIP process with the version 2 command while inside router configuration mode.

The requirements also asked that you prevent routers from automatically summarizing routes at classful boundaries – a possibly a tricky phrase to unpack. In short, RIP, even RIPv2, will advertise a route for an entire classful network in cases where the router connects to multiple classful networks. All three routers use subnets of class C network 192.0.1.0 on the WAN links. Two of the routers then connect to a subnets of a different network on their LAN links (R1 and R2). As a result, R1 and R2 connect to subnets of multiple classful networks, and RIP would automatically advertise summary routes for these networks.

To avoid those summary routes, just add the no auto-summary command in RIP configuration mode on only two of the three routers (R1 and R2). R3’s three interfaces all connect to subnets of the same class C network (190.0.1.0), so the auto-summary or no auto-summary command has no impact at all on router R3.

If you try this lab on your own gear or in VIRL, watch for routes for class A networks 10.0.0.0 and 20.0.0.0 with mask /8. These routes would occur if RIP on some router had automatic summarization enabled. (Per the requirements, you should have disabled automatic summarization.)

Finally, to enable RIP on the correct router interfaces, use the network network command. IOS compares the network parameter to the interface IP addresses configured on a router. With RIP (regardless of version) the network that is configured matches a whole classful network and cannot be limited by a subnet mask or wildcard mask (as with other routing protocols). All three routers connect directly to subnets of class C network 192.0.1.0. Routers R1 and R2 connect to a subnet of another network: network 10.0.0.0 off router R1, and 20.0.0.0 off router R2. As a result, the following network commands are required:

  • On R1 the two commands required would be: network 192.0.1.0 and network 10.0.0.0.
  • On R2 the two commands required would be: network 192.0.1.0 and network 20.0.0.0.
  • On R3 the one command required would be network 192.0.1.0.

Note that if you used extra network commands compared to those in the above list, RIPv2 would work. However, you should work to understand why other network commands on each router would not be needed. For instance, only R1 needs a network 10.0.0.0 command, because only R1 connects to a subnet of class A network 10.0.0.0.

Config Lab Storm's Purpose Revealed: Study for the New Exams!
New CCNA and CCENT Products, Availability, Timing
certskills
By certskills May 26, 2016 09:10
Write a comment

15 Comments

  1. HectorJ January 3, 21:09

    What I think is that leaving R3 without “no auto-summary” command option would result into 10.0.0.0/8 and 20.0.0.0/8 networks advertisement from that router.
    I mean, R3 recives a route from R1, which says “I have a route to 20.20.20.0/24”, but R3 forward this route as 20.0.0.0/0 to R1 (arriving with a hope count of 2). Then this one forward 20.0.0.0/0 to R2 (hope count of 3). Finally, R2 forward a route for 20.0.0.0/0 (different to the original subnet 20.20.20.0/24). By this time, R2 has two entries for the same subnet:
    20.20.20.0/24 (directly connected)
    20.0.0.0/8 (by means of RIP, via R1’s G0/1 interface)
    For 10.10.10.0/24, the logic is similar: R1 sends a route for this subnet, R3 recieves this one and advertises to R2 as 10.0.0.0/8. So R2 got to routes for the same subnet:
    10.10.10.0/24 (by means of RIP, via R1’s G0/1 interface)
    10.10.10.0/8 (by means of RIP, via R3’s G0/2 interface)
    So, for example, R2 will have the following route entries:
    10.0.0.0/8
    10.10.10.0/24
    20.0.0.0/8
    20.20.20.0/24
    Similar logic would be applied to R1’s route entries
    Wouldn’t it be like that?

    Reply to this comment
    • CCENTSkills January 12, 12:46

      Hi Hector,
      Sorry for the delay. I’m getting spotty notices from WordPress these days. Having to scan for comments. Anyway…
      The short answer is no. The auto-summary/no auto-summary impacts the router attached to both networks. R3 is the classic case for the mistake that R3 would summarize (if set to auto-summary). It would not. If R3 had one interface connected to network 20.0.0.0, it would summarize network 20.0.0.0. But with interfaces in network 192.168.1.0 only, it would not auto-summarize a route for 20.0.0.0 or 10.0.0.0.
      Hope this helps,
      Wendell

      Reply to this comment
  2. HectorJ January 3, 21:22

    I have some others questions regarding some CCNA subjects which would be better explained with a chart or a single image, so I’d like to know how I can attached them here or how I can send them to you

    Reply to this comment
    • CCENTSkills January 12, 12:47

      Hector,
      I don’t allow figures in comments for a few reasons. But I think if you placed a link it’d stick, assuming you can place the figure somewhere online and give me a link. Want to try?

      Reply to this comment
  3. HectorJ January 3, 21:27

    Thanks on advance, and forgive me for all those misspelling (“forwards”, the right one, ha-ha-ha!)

    Reply to this comment
  4. HectorJ January 18, 12:31

    I did this lab just on paper and i did it the same way you are showing on this answer.
    Later I tried with GNS3 and what I’ve described is the way this emulator behaves when
    this configuration was applied. I tracked RIP updates with “debug ip rip” and it seems
    like R3, the one with auto-summary, advertised 10.10.10.0/24 as 10.0.0.0/8 and 20.20.20.0/24
    as 20.0.0.0/8.

    I found almost the same behavior whith Packet Tracer.

    So, according with what you’ve explained what I understand is that when R3 recieves
    routing updates for 10.10.10.0/24 and 20.20.20.0/24 it records these entries and
    forwards those routes without summarizing, the same way it recieved them (net ID and
    mask). And this is because of R3 does not have interfaces which imply a class network boundary;
    all of them have ip address from the same class network.

    At least, I think that it happens this way on real live, isn’t it?

    It seems like, for GNS3 and Packet Tracer, the fact that those subnets are not part of the
    same class network of R3 interfaces, was enough to summarize them, despite that none of them
    (10.10.10.0/24 and 20.20.20.0/24) are directly connected to R3.

    I tried with a simpler configuration:

    | gi0/0 gi0/1 gi0/1 gi0/0 gi0/0 gi0/1 |
    |———[ R0 ]—————[ R1 ]—————-[ R2]————–|
    | |
    10.10.1.0/24 192.168.1.0/30 192.168.1.4/30 10.10.2.0/24

    R0:
    interface GigabitEthernet0/0
    ip address 10.10.1.254 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    ip address 192.168.1.2 255.255.255.252
    duplex auto
    speed auto

    router rip
    version 2
    passive-interface GigabitEthernet0/0
    network 10.0.0.0
    network 192.168.1.0
    no auto-summary
    !

    R1:
    interface GigabitEthernet0/0
    ip address 192.168.1.5 255.255.255.252
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    ip address 192.168.1.1 255.255.255.252
    duplex auto
    speed auto

    router rip
    version 2
    network 192.168.1.0

    R2:
    interface GigabitEthernet0/0
    ip address 192.168.1.6 255.255.255.252
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    ip address 10.10.2.254 255.255.255.0
    duplex auto
    speed auto

    router rip
    version 2
    passive-interface GigabitEthernet0/1
    network 10.0.0.0
    network 192.168.1.0
    no auto-summary

    Even with this one (simpler) the router with auto-summary option (R1), advertises 10.10.1.0/ 24 as
    10.0.0.0/8 to R2 and 10.10.2.0/24 as 10.0.0.0/8 to R0.

    Have ever you heard about such a behavior?

    Reply to this comment
    • CCENTSkills January 19, 09:59

      Hi Hector,
      Well, I’ve never heard that claim. But I haven’t tested that particular scenario in a long time, so I created your same topology and IP address config on a real pod… and got the same results as you. I tested further, and kept getting your results, rather than the results I would predict what I had written in the book. Short version: you’re correct, and the book is wrong on this point. I think I’ve tested enough to be confident of that fact.
      Note that I also tested EIGRP while I was there – easy enough, just add EIGRP config and also enable or disable auto-summary like you showed in your test. EIGRP does act as described in the book for RIP. That is, the middle router, with no interfaces connected to network 10.0.0.0, would not advertise a summary of 10.0.0.0/8. (That is what I expected for both RIP and EIGRP, but since I was greatly surprised about RIP’s behavior, seemed like I should test EIGRP).
      Also, in case you hadn’t gotten to them yet: EIGRP does support auto-summary, but OSPF does not, so of course I didn’t test OSPF for this same behavior.
      My apologies for the mistake. Thanks for persisting in your testing and comments. I will of course look for how I can adjust the wording in the book to clarify while not confusing everyone regarding the more straightforward parts of the feature. Thanks again,
      Wendell

      Reply to this comment
      • MarceloV November 24, 01:25

        Hello Wendell, about Hector’s question, I have been practicing this today with a simulation of this same lab in PT and I realized that too, that R3 (with auto-summary enabled) advertizes back 10.0.0.0/8 and 20.0.0.0/8, while he receives those routes with no autosummarization. from routers R1 y R2.

        1) So, taking in consideration what you said in your answer too, a router with auto-summary will advertise summarized routes not only directly connected routes, but also the routes he learned, in this case, with RIP?

        2) Maybe this is related to the same problem. I noted in R3 with a show ip route command the following result:

        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
        R 10.0.0.0/8 is possibly down, routing via 192.0.1.129, GigabitEthernet0/0
        R 10.10.10.0/24 [120/1] via 192.0.1.129, 00:00:03, GigabitEthernet0/0

        I don’t have problems to know that 10.10.10.0/24 route was learned through R1 (192.0.1.129) that does not have auto-summary enabled. But what does mean the first RIP route and why it says is possibly down? That route was also advertised for R1 and is summarized.

        Thanks in advance.

        Reply to this comment
  5. HectorJ January 18, 12:40

    Uuuuups!! It seems like something went wrong with my “chart”. I’ll try with something else.
    Thanks again

    Reply to this comment
  6. RN February 22, 11:50

    Hello Wendell,

    I have an interesting question that I think other will find useful to.

    In this output: (An image of the output is here: https://imgur.com/a/iJG54)
    ~~~
    R2#show ip route rip
    10.0.0.0/24 is subnetted, 1 subnets
    R 10.10.10.0 [120/1] via 192.0.1.1, 00:00:02, GigabitEthernet0/1
    192.0.1.0/24 is variably subnetted, 6 subnets, 2 masks
    R 192.0.1.128/26 [120/1] via 192.0.1.1, 00:00:02, GigabitEthernet0/1
    [120/1] via 192.0.1.126, 00:00:19, GigabitEthernet0/2
    R 192.0.1.192/26 [120/1] via 192.0.1.126, 00:00:19, GigabitEthernet0/2
    ~~~

    What does “192.0.1.0/24 is variably subnetted, 6 subnets, 2 masks” means?

    I understand that the class C 192.0.1.0/24 is indeed subnetted here, but I don’t know what are the *six* subnets and *two*
    masks the output is referring two. I count two subnets, and one /26 mask other than the classful /24.

    Thanks,

    RN

    Reply to this comment
    • CCENTSkills March 7, 09:58

      RN,
      “Variably subnetted” = using VLSM = one classful network with subnets that use >1 mask.

      I think the output is incomplete. To support the “6 subnets, 2 masks”, the list should include 6 subnets of that network, and you would see one other mask beside /26.
      Wendell

      Reply to this comment
  7. Tobias November 13, 07:27

    One concideration you might take in future content is that configuring exact network statements regarding those which should be advertised is helpful should the need to troubleshoot arise.

    This is a more broad suggestion to routing protocols in general, and not particular to RIP.

    More exact information as a general rule of thumb is always helpful.

    Reply to this comment
  8. SC May 4, 19:13

    Tried this lab in packet tracer with the correct configuration. However, when I check ‘show ip rip database’ on any of the 3 routers, I noticed the following lines between the directly connected routes:

    10.10.10.0/24 auto-summary
    20.20.20.0/24 auto-summary
    192.01.0/26 auto-summary
    192.0.1.64/26 auto-summary
    192.0.1.128/26 auto-summary
    192.0.1.192/26 auto-summary

    I checked ‘show ip protocols’ on R1 & R2 and confirmed “Automatic network summarization is not in effect.” What could cause this output? Would this be related to what Hector described in the comments above?

    Thanks!

    Reply to this comment
  9. Austin July 16, 12:26

    I have a lot of questions and a bit frustrated with this blog. ( love the blog but feel i am missing something)

    1) why is RIP being mentioned in this section (chapter 18) of the blog when it is a chapter 19 topic in the book?

    2) Where are the majority of users doing these labs? Packet Tracer is basically not an option for any of the Layer 3 Switching labs because it doesnt support multi layer switches, or at least i have not figured out how to make it work.

    3) The chapter sections should have a general comment section, as this comment pertains to the chapter as a whole and not to this specific lab/post.

    4) please can anyone make a recommendation on where/how to participate in these labs?

    Thanks in advance,
    Austin

    Reply to this comment
    • certskills Author July 16, 14:28

      Hi Austin,
      On your question, since you’re here in a Config Lab, and we commented to each other in a Packet Tracer Book Lab earlier today, let me start with a little context. Way back about 4 years ago I set about to create a large number of labs with some particular design points, and I’ve called them Config Labs, because they’re focused on small configuration tasks. Here’s a post that details what I was after: https://blog.certskills.com/think-config-config-labs/

      On your questions:

      1) I don’t know what you mean by your question I’m sure I’m missing something. I search on “18” in this post and don’t come up with any matches except in other comments from 2018. Sorry, I don’t know what you’re seeing that makes you think chapter “18”

      2) This one will be clear once you read the above link: they’re intended as paper/written exercises, with your option to do them in VIRL or PT at your own initiative. That said, PT does support L3 switching – just use the 3650 switch.

      3) Thanks for the feedback, always looking to improve the site.

      4) If by participate, you mean do them using real gear, VIRL, PT, etc., I think that link near the top reveals my intent. These are labs that anyone can do even if you do not have access to any tools. That said, this lab probably works, or comes close to working, in packet tracer. You’d have to use different interface numbers, but other than that, should be reasonably attempted.

      Wendell

      Reply to this comment
View comments

Write a comment

Leave a Reply to Tobias Cancel reply

Search

Categories