IOS Version 15 for a Cisco Home Lab – or Not

CCENTSkills
By CCENTSkills August 28, 2013 08:35

A good home #CCENT and #CCNA home lab does not require IOS 15.x. There, I said it.  Even though Cisco touts the new CCENT and CCNA as being based on IOS 15 (a pretty broad statement in itself), when you sit down to weigh the competing goals for your lab, version 15 is useful, but not a requirement. Today’s post develops these ideas a bit.

Other posts in this series:

A Brief Overview of IOS Version Numbers that Matter

I could write a whole book about how to build a home lab, and this one little section would probably get a whole chapter in the book. But to keep this blog post to a reasonable length, let me summarize a few facts, while admittedly leaving out some background:

  • Cisco numbers IOS software “versions”, the major new releases of Cisco IOS software for routers, with two numbers, like 12.4, or “version 12.4”.
  • Over time, Cisco creates new IOS releases inside each major version, making the IOS image files for each release available to their customers.
  • Cisco creates multiple sets of IOS releases for each version, with each set called an IOS release train. Each train can focus on other needs Cisco has for releasing software, for instance, some trains may strive to keep the code stable, while others add every new feature and therefore risk more bugs.
  • The only two trains we will discuss are the mainline train (which has no suffix letters after the version), and the T-train (with suffix letter T, e.g., “12.4T”).
  • A T-train version has the same features – those topics you want to study – as the next mainline release. E.g.:
    • 12.3 (mainline) and 12.2T support the same features
    • 12.4 (mainline) and 12.3T support the same features
  • 12.4T, the latest version T-train in version 12, stands alone for various reasons, at least in how it’s used for thinking about home labs.
  • Yes, Cisco skipped versions 13 and 14 because off perceived bad luck in different cultures. 😉
  • 15.0M was the next version (that we care about for home labs) after 12.4T.

Choosing an IOS Image in the Right Version, with the Right Features

When you look for used gear, you can look for the used router, but you also need to know what IOS image that router has installed. Most of you will not have the ability to download and upgrade that IOS to a new image. So, when you buy that router, you need to pay close attention to the IOS. When you pick an IOS version for a router in your home lab, you need to choose the right IOS version for several reasons:

  • The Version Determines how Current the Commands Are: The more current, the more likely the commands work just like you will see on the exam, and in books.
  • The Version Determines (in part) the Commands Supported: The IOS version in part defines what features are supported, and therefore what commands are supported.
  • The Feature Set Associated with the IOS Image Determines (in part) the Commands Supported: Cisco adds features to each IOS based on the IOS feature set.

I’ll break down this first reason for the rest of this post.

IOS Versions Can Change Command Syntax and Output

Say you buy a used router, a 2501, with 12.3 IOS. If you then buy a brand new 2901 router, with the most recent M-train version (15.3M), you are five IOS versions behind on the 2501, at about a 10-year time span of when these IOS versions came into the market.

And you can still learn a lot for CCNA with that 2501 – but some of the commands may work a little differently.

When Cisco updates an IOS, the vast majority of the commands do not change. In particular, config commands often remain unchanged. The output of show commands changes in a higher percentage of commands, but many show commands do not even change. Even if the output changes, the changes often add new information, or change the format, but they do not remove information or change the meaning of information. In fact, most experienced network engineers do not even notice some of these changes unless they look at the output of the same command, in different IOS versions, side-by-side.

But changes do happen, so let me give a few examples:

  • The ip access-group x [in|out] command. In earlier IOS versions, the “in” or “out” was optional (as shown here in square brackets), and if not listed, IOS assumed “in”. Somewhere around IOS 12.2 (that’s a guess – it’s an old memory in my skull), IOS changed to require us to type either “in” or “out”.
  • ACL editing: Cisco has continued to update and improve IOS ACL support each version. However, IOS versions 12.2 and 12.3 saw a lot of improvements that Cisco included in the scope of CCNA at the time, namely ACL line editing, line numbers, and named ACLs. (Aside: to avoid this ACL mess today, use 12.4 mainline, or later IOS versions, and you should be good for current CCNA study.)
  • The show ip route command: IOS changed the output of this command in one significant way starting at 15.0M. This command now lists “local” routes, which are routes on a local router about the local routers own interface IPv4 addresses. With older IOS versions, the output would not list the local routes. Here’s a sample from the ICND1 Cert Guide:

 

Example of the show ip route Command’s Local Routes

IOS 15: Not a Huge Deal for a Home Lab

Do you have to have a version 15.something IOS in your home lab routers to study for the new CCENT and CCNA exams? In my opinion, no. Here’s why:

Comparing IOS 15 to the most recent IOS 12 versions, Cisco has indeed changed the output of quite a few show commands. However, I only came across one change that would impact your study. Do you need to spend three times as much on your used routers just to get support for that one command? Probably not.

The one command that did change enough to matter, show ip route, can be learned by reading the book. If your lab has routers with say 12.4T, you won’t see those local routes. But the book shows several examples with the local routes included. And to be honest, I wouldn’t be surprised a bit if the exam still had a few questions that showed the old format without local routes either. To save a few hundred dollars on your lab, I think you can just do without.

Thinking about the used market, and the IOS versions supported by cheap used routers, can help put some perspective on the need vs. desire for version 15.0. IOS versions 12.4 and 12.4T are both current enough to avoid many historical command changes. IOS versions 12.4 and 12.4T both work on a variety of cheap used routers. To get 15.anything, you will need at least an 1800 series or 2800 series router, or a 87x router, all of which still cost into the hundreds per router even in the used market. Useful? Yes. Worth the money just to get to IOS 15.x? Maybe, but maybe not. I’ll develop that further over the next post or two.

Conclusions

For a CCENT or CCNA home lab for the 100-101, 200-101, and 200-120 exams:

  • 15.x is not required, although it’s better than running older IOS versions
  • 12.3/12.2T is probably a good absolute minimum (but not Wendell’s preference)
  • 12.4/12.3T is noticeably better than 12.3/12.2T due to ACL support
  • 12.4T is the sweet spot for the best of the “old” 12.x version, with many older routers supporting it
  • If you really want IOS 15, many in the 1800/2800 series, and the 870 series, support up through 15.1M
  • Pay close attention to show ip route if you go with a version 12 IOS.

 

 

Narrowing Your Router Search Based on IOS Version
#CCNA and #CCENT Lab Topologies
CCENTSkills
By CCENTSkills August 28, 2013 08:35
Write a comment

25 Comments

  1. Scott Murphy August 28, 12:47

    Great Information… Thanks!!!!

    Reply to this comment
  2. Zorrs August 29, 01:15

    great…thanks alot. just got one question, does every router support all the ISO version out their. can we just install any ISO on any Router. can you make a post on this topic

    Reply to this comment
  3. CCENTSkills Author August 29, 11:09

    Zorrs,
    Well, I don’t know about a whole post, because it’s a quick answer.
    A single router model does not support all IOS versions. Cisco compiles IOS for each specific model, or for several related models that use the same chipsets.
    For example, a Cisco 2501 router, which is really old, supports many individual IOS versions, and countless releases inside those versions. However, Cisco quit selling 2501’s as new routers somewhere in the late 1990s. At some point, Cisco quit compiling IOS images for 2501s, to save support costs, because no one actually used 2501’s in production any more, etc. So, if you check my 2501 page starting from certskills.com/labgear, you’ll see the latest IOS version as 12.2T/12.3. You can’t run 12.3T/12.4 on a 2501. And you can’t go get a 12.3T/12.4 IOS image for another model router, or even a more recent IOS image, and run it on that 2501.
    …which then requires us to think about the latest IOS supported by a given model – and one reason for this blog post! 😉
    Wendell

    Reply to this comment
    • Quilvia March 25, 00:02

      I am having tublores installing it on my PC with windows 7 it keeps telling me it is not a trusted thing for windows 7 do you want to go ahead Yes or No, can you explain how to fix this problem Thank you

      Reply to this comment
      • CCENTSkills Author March 29, 14:09

        Hi Quillivia,
        I think you may have missed a fundamental piece of the puzzle, so let me be more exact: IOS is not a Windows application. You can’t install it on Windows, and if you could, it probably wouldn’t do anything useful. IOS is an OS, created by Cisco, that runs on Cisco router hardware.
        Hope this helps!
        Wendell

        Reply to this comment
  4. Jonathan August 29, 15:02

    Thanks for such a great post! It was very enlightening. I’m studying for CCNP but there are a lot of basic information, like details of OS versions, that I’m lacking. This was very helpful. Any suggestion on books that deal with explaining basic but yet detail information that Cisco Press Books miss on? Like explaining every file on a flash drive for most router/switch? Or detail differences in all the versions of IOS (to complement your post). Possibly even cover hardware components on routers/switches? Or would that be a waste of time for someone like myself which is seeking the CCIE path?

    Reply to this comment
    • CCENTSkills Author August 29, 17:21

      Hi Jonathan,
      Well, that’s a good question. I can give some tactical options. And I don’t think it’s a waste of time.
      – Get a Cisco “Product Quick Reference Guide” direct from Cisco. About $10 plus shipping. Or look for the free PDF version at cisco.com. Then get busy reading! It’s a great way to just get more familiar with the product line a little at a time.
      – Play around with the Cisco feature navigator, again free. http://www.cisco.com/go/fn. You can search based on feature, router model, etc, and learn what routers support what features.
      – I don’t know of a book like you’re envisioning. I had thought of writing one that was just a deeper version of this blog series, with more detail and specifics.
      – I don’t think that knowing the product line better actually helps you pass CCIE. But it helps for the real job.
      Hope this helps a little at least!
      Wendell

      Reply to this comment
  5. Herman October 17, 13:05

    I have a question about IOS 15 licensing, and as it relates to home labs, assuming you bought the least expensive router you could find that runs IOS 15, you’d still have to buy additional licensing to use advanced features, right? I guess it’s less of an issue if you’re studying for CCENT or CCNA, but if you’re pursuing CCNP, then it may become problematic?

    Reply to this comment
  6. CCENTSkills Author October 17, 13:12

    Hi Herman,
    Short answer is yes. Indeed, to be ready for CCNP and beyond, you’d need a similar list of CCNP features, and then some time to spin through the feature navigator. certskills.com has some feature lists for current CCNP features, but given that CCNP hasn’t revved for a few years, none of that gets into 15.x. But it’s a good list of features to peruse relative to your question.
    Wendell

    Reply to this comment
  7. Zak October 26, 10:36

    Hi

    I have purchased some Cisco used kit for my home lab (2811’s, 1841’s, 3560’s and 3550’s). The software versions on these are below the recommended by the INE spec. Where can I download IOS images as follows:

    12.4(10)A c2600-adventerprisek9-mz.124-10a.bin ** EQUIV version required for 2811 **

    12.4(24)T1 c1841-adventerprisek9-mz.124-24.T1.bin
    12.2(44)SE c3560-advipservicesk9-mz.122-44.SE.bin
    12.2(25)SEC2 c3550-ipservicesk9-mz.122-25.SEC2.bin
    12.2(15)T17 c2500-is-l.122-15.T17.bin

    Or, do I need to purchase these images? If so, how much do they cost and where do I get them from? When I tried to download any 12.X image from the Cisco website, I received a banner message advising me that I need a service contract.

    Any help appreciated.

    Reply to this comment
  8. CCENTSkills Author October 28, 07:42

    Hi Zak,
    To get the right to get updated (later version/release) software, you need to have bought the routers through an authorized channel and have purchased a service contract. That’s usually too much $$ for a home lab, by far. Most used channels do not support a service contract, or if they do, it does not include any software upgrades, because behind the scenes that process cuts Cisco out of the loop. So, picking the right IOS version/release and feature set is truly a purchase-time decision. I know of no way today for you to upgrade the IOS on the routers you have already bought.

    That’s not to say what you bought wouldn’t be useful. As I’ve written in this series, I’ve spelled out what extra you get with later versions and better feature sets, but much of CCNA is even in the 12.2 versions on some of your oldest routers.

    Check out the tables at certskills.com, for router features, to get a sense for what CCNA features you can find at some common versions and feature sets.
    Wendell

    Reply to this comment
  9. Aaron January 4, 05:57

    Hi Wendell, quick question for you if you can… I’m working on picking up gear for a “multipurpose” home lab (not just CCNA, but that is a significant reason) that will eventually be used for a permanent network. I currently have a 3550 and 2 2970’s, and am about to pick up the routers. My question is, is a 3825 (running c3825-adventerprisek9-mz.151-4.M5.bin
    ) a solid choice, or would I be better off with a somewhat more common platform like 1841’s? I’m interested in the 3825’s partly for the IOS version (full IPv6 support)but also, dual Gigabit and plenty of room for expandability as far as WIC’s, etc.

    Thanks in advance for any input you can provide!

    Reply to this comment
  10. CCENTSkills Author January 8, 09:03

    Hi Aaron,
    For the scenario you describe, the 3825’s would be fine. My main question would how much longevity you need once you move it to production. Look at cisco.com/go/fn for the specific 3825 series, and look for the latest IOS train. Looks like 15.1T is the latest in the M and T trains. So, if the current 15.1M version you mentioned does what you want, and you aren’t worried about supporting future IOS features, then I’d be fine with it. But note that my concerns would be on the production side – as a CCNA lab device, it’s fine.
    Wendell

    Reply to this comment
  11. sadek February 17, 16:10

    Thank you for your post I love to have home lab with routers and switches that can be useful for studing ccnp and ccie besides ccna and not just for r&s but for voice, security, etc.
    I would not purchase a big ccie home lab but I just want to chose switchs and routers that will be useful for ccie lab I do not want devuces that will not be useful in future whats your advice and did your post applies for switchs also specifically 2960 I do find switchs with 12.2 and 15 ios version and if your post applies for switchs I think I will chose switch with ios 15.
    Thank you in advance.

    Reply to this comment
    • CCENTSkills Author February 18, 09:24

      Hi Sadek,
      Thanks for the post.
      I’ve not personally taken the time to research the current prices and IOS version for 3550 and 3560. They’ve always been the sweet spot for CCNP switching, where you need some layer 3 switches, particularly 3550s. Cisco made the 3550 SM’s (cheaper, layer 2) so that they could be field upgraded to EM (layer 3 capable), so a lot of the used 3550’s in the market were basically SM’s w/ EM software loaded. Made for a lot of cheap layer 3 switches. Anyway, you might try the forums at one of the CCIE prep company for a discussion of the current best L3 switches in terms of cheap, used, but useful.
      Thanks,
      Wendell

      Reply to this comment
  12. Chris Branca February 27, 19:26

    thank you for this post. I have been struggling to confirm if my lab will suffice. cisco asa 5505, two 2900x, two 3750 catalysts.
    however, since this is just for cert training..im not even gonna use my equip. i have 12.4T iso/bins. am gonna slap 12.4T bin file into gns3 and rock it up. thanks again.

    Reply to this comment
  13. Sajith September 27, 00:07

    Hi Wendell,

    As per the new CCNP R&S 300-101 exam, Do I Really need to look for the IOS 15.2 than 15.1 version ?
    Routers which supports ios 15.2 are way too expensive for the home lab.
    1841 and 2800 series does not support ios 15.2 but much cheaper.

    Thanks in Advance,
    Sajith

    Reply to this comment
  14. CCENTSkills Author September 27, 08:21

    Hi Sajith,
    I haven’t looked at the new CCNP track in much depth yet. However, it’s truly a matter of degrees. You could probably do a large percentage of CCNP ROUTE – call it half at least – only really old IOS like say 12.2. But I haven’t (and probably won’t) drag through the detail feature-by-feature for CCNP R/S this time around.
    Frankly, if your timeframe isn’t too urgent, I’d get a few cheaper routers, and they watch and wait for a free version of VIRL. Or just start trying out the sim that’s in the All-in-one VM at developer.cisco.com.
    Wendell

    Reply to this comment
  15. Zonet January 20, 16:59

    Hello, thanks for the article. My question, I have two 3500xl switches and two 2600 routers. Do you think I could still use them to study for the new ccent and ccna?

    Reply to this comment
    • CCENTSkills Author February 4, 10:13

      Hi Zonet,
      Sure. You just don’t get all the features needed for the current exam. Those devices don’t support the latest IOS versions, so you lose a little, but they are still useful. For sure, if you already own them, get into them, start learning, and make progress. Then you can decide how badly you might want other gear vs. saving the $$.
      Wendell

      Reply to this comment
  16. tmell173 February 3, 16:43

    So does it mean if I download an iOS marked for a 2800 router it will work for a 3750 switch ?

    Reply to this comment
  17. CCENTSkills Author February 4, 10:11

    tmell173,
    Nope. You must download the image for that particular model.
    Thanks,
    Wendell

    Reply to this comment
  18. Paul Sutton March 5, 20:14

    I’ve seen 3560 switches in many flavors for about $100. That said, unless you up the ante and go for 3560x or 3560e, you’ll find that they cannot be upgraded to v15, though I’ve seen a few advertised as having v15 installed. The problem is that what they have installed is called “universal,” and no, it doesn’t mean that it will work on anything. It means it’s a base set of IOS, lacking the nice things one needs to know to pass CCNP or even CCNA, like encryption.

    As to IOS though, if you have an account with Cisco, you can find a lot of upgrade software for many switches and routers, at least in the 12.2 range. v15 I’ve seen quoted as costing $600 per copy on the web. Ouch!

    Reply to this comment
  19. Yu April 12, 04:28

    Hi Wendll,

    I have questions about cisco 1800 router.

    I know that if I have 12.4T IOS in it, then the services available depend on the Image (base, security, voice, enterprise services, advance services).

    I know that IOS 15.x can work on cisco 1800 series router. But what confuses me is the following:

    – Based on my reading IOS 15.x image has all the services and you enable them by using licenses. I thought this is the same thing required for all router (e.g. 1800 ISR series, 2901 ISR G2, 1921 ISR G2, etc). and I thought that owners of old routers who purchased IOS 12.2 or 12.4(T)[advance enterprise services] and want to upgrade to IOS 15.x need to pay for the each license (data, voice, security) to enable the features again. But I found that in 15.x there is different types 15.x advance services, 15.x advance enterprise, 15.x advance security. Then I got confused! Are these versions for old routers (e.g. 1800 series routers) and these versions do not work on ISR G2 routers? Do these IOSs (15.x advance enterprise, 15.x advance security) need licenses to function? if yes then why they have been created if you can have one IOS image and open it as you want depend on licenses you have.

    Thank you Mr. Wendell. I hope to find the answer here in your blog.

    Reply to this comment
    • CCENTSkills Author April 14, 10:21

      Hi Yu,
      Unfortunately, Cisco’s traditional licensing is not that simple. And Cisco’s been working to find better ways to do licensing for a while now – at least 5 years that I’ve been aware of, and probably a lot longer than that. In fact, I’ve made a habit of seeking out a few buddies at the Cisco Live show each year, listening to sessions, just to keep an eye on where it’s headed. It’s a big deal for real jobs, and of course it trickles down to the exams in a small way as well.

      I won’t be able to give a complete answer here – the answer is much too big and complex. But I think I can give you a few insights. Then, searching on Cisco.com can lead to lots of background info.

      First, don’t think of “router” as having one licensing structure over the long term. EG, Cisco models X, Y, and Z, for certain calendar years, may have coincidentally supported the same feature sets by name. In those same years, other Cisco router models supported a different group of feature sets. Why? Different models play different roles, and Cisco made feature sets that worked well for their customers for how they used those routers.

      You made a statement that you “thought that owners of old routers…” – go back and look at that statement. Say you own a router, w/ 12.2 IOS, and advanced enterprise services. If a) it’s had a maintenance contract all this time, and b) the hardware supports 15.x, you are entitled to download and install 15.x. I’m not sure how Cisco maps the old feature set to the newer more standard data, voice, etc. feature sets. Then, if the router you own has been without a maintenance contract, chances are you can’t upgrade it legally at all, even if that model of router supported some 15.x release. The reasoning: maintenance includes hardware support, so it’s hard to take a device that’s been without a maintenance contract and get a new maintenance contract, because Cisco risks your calling to say the hardware died. It’s kind of like you can’t let your car’s warranty expire, drive it for a few more years, and then get a new warranty when it starts to have mechanical problems. And the software update rights tie into those same service contracts.

      So, if you have an older router model, and if it’s been under a maintenance aka service contract, and it supports some 15.x version, it can be legally upgraded. Not sure about the mapping of feature sets. Without that series of facts, I don’t think you can upgrade it.

      Finally, to figure out what is and isn’t supported, just try the cisco feature navigator (www.cisco.com/go/fn). Pick a model series, and see what IOS versions are supported.

      Also – if it wasn’t clear – from one of your closing questions – yes, an image meant for one router will not run on a different router. There may be small groups of routers that share the literally identical images (e.g., most of the 1800 series use the same images). So yes, you can’t take the image off a 2901 ISR G2 and load it in an 1841.

      Hope this helps!
      Wendell

      Reply to this comment
View comments

Write a comment

Your e-mail address will not be published.
Required fields are marked*

Subscribe

Subscribe to our mailing list and get interesting stuff and updates to your email inbox.

Search

Categories